summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/unix/posix/tools/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-03-24 23:14:36 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-03-24 23:14:36 +0000
commit244ecd9fb87dec2aeed6fb97d37dd8a43f9be4cc (patch)
tree6bffdff113f276d1e2c74064582281d556305ff8 /c/src/lib/libbsp/unix/posix/tools/Makefile.am
parent Fix based on bug report from Ralf Corsepius <corsepiu@faw.uni-ulm.de>: (diff)
downloadrtems-244ecd9fb87dec2aeed6fb97d37dd8a43f9be4cc.tar.bz2
These files were not added as part of a recent patch from
Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Diffstat (limited to 'c/src/lib/libbsp/unix/posix/tools/Makefile.am')
-rw-r--r--c/src/lib/libbsp/unix/posix/tools/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/unix/posix/tools/Makefile.am b/c/src/lib/libbsp/unix/posix/tools/Makefile.am
new file mode 100644
index 0000000000..d30f35110b
--- /dev/null
+++ b/c/src/lib/libbsp/unix/posix/tools/Makefile.am
@@ -0,0 +1,21 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign
+ACLOCAL = @ACLOCAL@ -I $(RTEMS_TOPdir)/aclocal
+
+if HAVE_PERL
+perl_scripts = shmdump semdump
+endif
+
+noinst_SCRIPTS=runtest looptest $(perl_scripts)
+
+# HACK: install to build-tree
+install-exec-local: $(SCRIPTS)
+ $(mkinstalldirs) $(PROJECT_ROOT)/${RTEMS_BSP}/tests
+ for i in $(SCRIPTS); do \
+ $(INSTALL_SCRIPT) $$i $(PROJECT_ROOT)/${RTEMS_BSP}/tests ; \
+ done
+
+include $(top_srcdir)/../../../../../../../automake/local.am