summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/unix/posix/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-18 20:40:09 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-18 20:40:09 +0000
commit7f09abec3eeeca99cd0d8312a5dae97485c38525 (patch)
tree4410e2f01220e6ed39974a44e51f243daaba205c /c/src/lib/libbsp/unix/posix/Makefile.am
parent2008-09-18 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-7f09abec3eeeca99cd0d8312a5dae97485c38525.tar.bz2
2008-09-18 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, startup/bspstart.c: Add bsp_get_work_area() implementation and use more of the BSP Initialization Framework. * startup/bspgetworkarea.c, startup/bsppost.c: New files.
Diffstat (limited to 'c/src/lib/libbsp/unix/posix/Makefile.am')
-rw-r--r--c/src/lib/libbsp/unix/posix/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/unix/posix/Makefile.am b/c/src/lib/libbsp/unix/posix/Makefile.am
index 0e5c9c5b97..5832af8802 100644
--- a/c/src/lib/libbsp/unix/posix/Makefile.am
+++ b/c/src/lib/libbsp/unix/posix/Makefile.am
@@ -40,7 +40,8 @@ noinst_LIBRARIES =
## endif
startup_SOURCES = startup/bspclean.c ../../shared/bsplibc.c \
- ../../shared/bsppredriverhook.c startup/bspstart.c \
+ ../../shared/bsppredriverhook.c ../../shared/bsppretaskinghook.c \
+ startup/bspstart.c startup/bsppost.c startup/bspgetworkarea.c \
startup/setvec.c ../../shared/bootcard.c
## for now always using main.c style startup
##if !HAS_CXX