summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon3/configure.ac
diff options
context:
space:
mode:
authorDaniel Hellstrom <daniel@gaisler.com>2012-04-19 15:46:10 +0200
committerGedare Bloom <gedare@rtems.org>2012-04-19 12:34:21 -0400
commit62694fd68fd8b3cd71cea9d3a2541edb7b9b91bb (patch)
treebe0be07b4b65d3b9faf9fbe95d98e4bb417c7ee2 /c/src/lib/libbsp/sparc/leon3/configure.ac
parentLEON3: add console attributes such as parity and baudrate (diff)
downloadrtems-62694fd68fd8b3cd71cea9d3a2541edb7b9b91bb.tar.bz2
LEON3: add console interrupt mode support
The comment in configure.ac is probably inherited from the LEON2 BSP. The LEON3 console driver implements a "flush" mechanism on console_close() in order to solve the problem described with sis/LEON2. Signed-off-by: Daniel Hellstrom <daniel@gaisler.com>
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon3/configure.ac')
-rw-r--r--c/src/lib/libbsp/sparc/leon3/configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/sparc/leon3/configure.ac b/c/src/lib/libbsp/sparc/leon3/configure.ac
index 6d86386101..3f2d445e92 100644
--- a/c/src/lib/libbsp/sparc/leon3/configure.ac
+++ b/c/src/lib/libbsp/sparc/leon3/configure.ac
@@ -26,10 +26,7 @@ RTEMS_BSPOPTS_SET([CONSOLE_USE_INTERRUPTS],[*],[0])
RTEMS_BSPOPTS_HELP([CONSOLE_USE_INTERRUPTS],
[The leon3 console driver can operate in either polled or interrupt mode.
Under the simulator (especially when FAST_UART is defined), polled seems to operate
-better. It is common for a task to print a line (like the end of test message) and
-then exit. In this case, the program returns control to the simulator command line
-before the program has even queued the output to the uart. Thus sis has no chance
-of getting the data out.])
+better.])
RTEMS_BSPOPTS_SET([SIMSPARC_FAST_IDLE],[*],[])
RTEMS_BSPOPTS_HELP([SIMSPARC_FAST_IDLE],