summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon3/configure.ac
diff options
context:
space:
mode:
authorDaniel Hellstrom <daniel@gaisler.com>2014-05-21 09:37:16 +0200
committerDaniel Hellstrom <daniel@gaisler.com>2014-10-06 14:44:44 +0200
commit5e92a40a38dc65958e56313f3a638cfe20c4b82b (patch)
treeb5a55d61117b8ecde07fd5b7dc78f1af1ac8e28e /c/src/lib/libbsp/sparc/leon3/configure.ac
parentSPARC: Fatal_halt use source and exit codes (diff)
downloadrtems-5e92a40a38dc65958e56313f3a638cfe20c4b82b.tar.bz2
LEON3: use CPU_Fatal_halt for halt
By removing the bsp_reset() mechanism and instead relying on the CPU_Fatal_halt() routine SMP and single-core can halt by updating the _Internal_errors_What_happened structure and set the state to SYSTEM_STATE_TERMINATED (the generic way). This will be better for test scripts and debugger that can generically look into why the OS stopped. For SMP systems, only the fatal-reporting CPU waits until all other CPUs are powered down (with a time out of one clock tick). The reason why a fatal stop happend may be because CPU0 was soft-locked up so we can never trust that CPU0 should do the halt for us.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon3/configure.ac')
-rw-r--r--c/src/lib/libbsp/sparc/leon3/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/sparc/leon3/configure.ac b/c/src/lib/libbsp/sparc/leon3/configure.ac
index 8ace8a30fd..c29dc529bb 100644
--- a/c/src/lib/libbsp/sparc/leon3/configure.ac
+++ b/c/src/lib/libbsp/sparc/leon3/configure.ac
@@ -43,7 +43,7 @@ RTEMS_BSPOPTS_HELP([BSP_POWER_DOWN_AT_FATAL_HALT],
[If defined, CPU is powered down on fatal exit. Otherwise generate system
error which will hand over to debugger, simulator, etc.])
-RTEMS_BSP_CLEANUP_OPTIONS(0, 1, 1)
+RTEMS_BSP_CLEANUP_OPTIONS(0, 0, 1)
RTEMS_BSP_LINKCMDS
# Explicitly list all Makefiles here