summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon3/Makefile.am
diff options
context:
space:
mode:
authorDaniel Hellstrom <daniel@gaisler.com>2017-05-09 16:00:56 +0200
committerDaniel Hellstrom <daniel@gaisler.com>2017-05-14 12:32:00 +0200
commit84e4d10ca346e7c89314845420a650b6dab316b4 (patch)
tree383fdb88425c721999aec3d36f9385e8347dd391 /c/src/lib/libbsp/sparc/leon3/Makefile.am
parentleon, grtm: SMP support by using spin-locks (diff)
downloadrtems-84e4d10ca346e7c89314845420a650b6dab316b4.tar.bz2
leon, apbuart: remove old RAW UART driver
This driver was initially intended for APBUART access on GRLIB PCI peripherals (AMBA-over-PCI). There are already many APBUART drivers for LEON. Instead of using this one the termios APBUART should work on AMBA-over-PCI systems with recent changes on LEON3, however that has not been tested yet.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon3/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon3/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/sparc/leon3/Makefile.am b/c/src/lib/libbsp/sparc/leon3/Makefile.am
index 83e1dff7d2..52f6b569a9 100644
--- a/c/src/lib/libbsp/sparc/leon3/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon3/Makefile.am
@@ -170,8 +170,7 @@ libbsp_a_SOURCES += ../../sparc/shared/spw/grspw_router.c
# UART
include_bsp_HEADERS += ../../sparc/shared/include/apbuart.h \
../../sparc/shared/include/apbuart_termios.h
-libbsp_a_SOURCES += ../../sparc/shared/uart/apbuart.c \
- ../../sparc/shared/uart/apbuart_termios.c
+libbsp_a_SOURCES += ../../sparc/shared/uart/apbuart_termios.c
# I2CMST
include_bsp_HEADERS += ../../sparc/shared/include/i2cmst.h