summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon3/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2017-12-28 23:21:14 +1100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-01-04 11:54:35 +0100
commit6897cb1d7c3a5b661de77098e83c0f2b5174dfd0 (patch)
tree1e8a220f7491da7af96261656077cc4bd4bb9a6e /c/src/lib/libbsp/sparc/leon3/Makefile.am
parentbsp/pc386: Do not install console_private.h (diff)
downloadrtems-6897cb1d7c3a5b661de77098e83c0f2b5174dfd0.tar.bz2
bsps: Add AM_CPPFLAGS to special case CPPFLAGS
This is necessary to pick up mandatory flags provided by the build system. Update #3254.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon3/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon3/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/sparc/leon3/Makefile.am b/c/src/lib/libbsp/sparc/leon3/Makefile.am
index 7407bebb3e..b73569d222 100644
--- a/c/src/lib/libbsp/sparc/leon3/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon3/Makefile.am
@@ -229,7 +229,7 @@ include_bsp_HEADERS += include/watchdog.h
# Cache
libbsp_a_SOURCES += ../../../libcpu/shared/src/cache_manager.c
libbsp_a_SOURCES += include/cache_.h
-libbsp_a_CPPFLAGS = -I$(srcdir)/include
+libbsp_a_CPPFLAGS = $(AM_CPPFLAGS) -I$(srcdir)/include
# GR712
include_bsp_HEADERS += ../../sparc/shared/include/grascs.h