summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon3/Makefile.am
diff options
context:
space:
mode:
authorDaniel Cederman <cederman@gaisler.com>2017-07-14 14:12:07 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-07-17 07:43:20 +0200
commit4debaca6d2d6248f97bf3fbbd39a8afca0ab4beb (patch)
tree562703be35c45ab8b1c21fd2674093ff7044a77e /c/src/lib/libbsp/sparc/leon3/Makefile.am
parentsparc: Add assembly workaround for LEON3FT B2BST errata (diff)
downloadrtems-4debaca6d2d6248f97bf3fbbd39a8afca0ab4beb.tar.bz2
bsps/sparc: Add leon3 BSP variants
Rename NGMP to GR740 and add configs for UT699, UT700, and GR712RC The UT699 requires -mcpu=leon as it does not support the CAS instruction provided by -mcpu=leon3. It also requires -mfix-ut699 for errata fixes. UT700 and GR712RC requires the -mfix-ut700 and -mfix-gr712rc flags that have been recently added to GCC's master and 7-branch. Remove -msoft-float from the leon3 config to make the more common case of using the FPU the default. Update #3057.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon3/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon3/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/sparc/leon3/Makefile.am b/c/src/lib/libbsp/sparc/leon3/Makefile.am
index 52f6b569a9..cd591dd56e 100644
--- a/c/src/lib/libbsp/sparc/leon3/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon3/Makefile.am
@@ -26,7 +26,10 @@ project_lib_DATA = start.$(OBJEXT)
dist_project_lib_DATA += ../shared/startup/linkcmds.base
dist_project_lib_DATA += startup/linkcmds
dist_project_lib_DATA += startup/linkcmds.leon3
-dist_project_lib_DATA += startup/linkcmds.ngmp
+dist_project_lib_DATA += startup/linkcmds.ut699
+dist_project_lib_DATA += startup/linkcmds.gr712rc
+dist_project_lib_DATA += startup/linkcmds.ut700
+dist_project_lib_DATA += startup/linkcmds.gr740
noinst_LIBRARIES += libbsp.a
libbsp_a_SOURCES =