summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon3/Makefile.am
diff options
context:
space:
mode:
authorDaniel Hellstrom <daniel@gaisler.com>2011-12-16 14:10:57 +0100
committerDaniel Hellstrom <daniel@gaisler.com>2015-04-17 01:10:17 +0200
commit46e41c98b30e9084e8a706129a78327da27c22a4 (patch)
tree5101111e5fc61a31cabf9c1370a06aa98051f7ae /c/src/lib/libbsp/sparc/leon3/Makefile.am
parentLEON3: new Console driver, APBUART driver using Driver Manager (diff)
downloadrtems-46e41c98b30e9084e8a706129a78327da27c22a4.tar.bz2
LEON: replaced old BSP PCI layer with new generic libpci PCI layer
The old code used a limited PCI configuration library, which was duplicated into LEON2 and LEON3 BSP pci.c together with respective Host controller PCI interface. The LEON2 BSP had support for AT697 PCI, and LEON3 for GRPCI PCI Host controller. With this update new PCI Host drivers are added, and all support the new generic PCI Library: * AT697 PCI (LEON2 only) * GRPCI (LEON2-GRLIB and LEON3) * GRPCI2 (LEON2-GRLIB and LEON3) * Actel PCIF GRLIB Wrapper (LEON3 only) The LEON2 BSP is defined as big-endian PCI in bsp.h, since the AT697 supports only big-endian PCI.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon3/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon3/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/sparc/leon3/Makefile.am b/c/src/lib/libbsp/sparc/leon3/Makefile.am
index f263ab607a..a451208904 100644
--- a/c/src/lib/libbsp/sparc/leon3/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon3/Makefile.am
@@ -100,9 +100,14 @@ libbsp_a_SOURCES += \
../../shared/src/irq-legacy.c \
../../shared/src/irq-server.c \
../../shared/src/irq-shell.c
+
# PCI
-include_HEADERS += ../../sparc/shared/include/pci.h
-libbsp_a_SOURCES += pci/pci.c ../../sparc/shared/pci/pcifinddevice.c
+include_HEADERS += ../../sparc/shared/include/grpci2.h
+libbsp_a_SOURCES += ../../sparc/shared/pci/grpci.c
+libbsp_a_SOURCES += ../../sparc/shared/pci/grpci2.c
+libbsp_a_SOURCES += ../../sparc/shared/pci/pcif.c
+libbsp_a_SOURCES += ../../sparc/shared/pci/pci_memreg_sparc_le.c
+libbsp_a_SOURCES += ../../sparc/shared/pci/pci_memreg_sparc_be.c
# B1553BRM
include_HEADERS += ../../sparc/shared/include/b1553brm.h \