summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon2/configure.ac
diff options
context:
space:
mode:
authorDaniel Hellstrom <daniel@gaisler.com>2014-05-20 17:45:07 +0200
committerDaniel Hellstrom <daniel@gaisler.com>2014-10-06 13:19:18 +0200
commit9bd7b3b1a26adc41678ec4d4a1d97f057cdb43a7 (patch)
treee696df2a0aa20c45ac84c3d5de06a53731599495 /c/src/lib/libbsp/sparc/leon2/configure.ac
parentSPARC: add BSP specific error handler (diff)
downloadrtems-9bd7b3b1a26adc41678ec4d4a1d97f057cdb43a7.tar.bz2
SPARC: Fatal_halt use source and exit codes
The Fatal_halt handler now have two options, either halt as before or enter system error state to return to debugger or simulator. The exit-code is now also propagated to the debugger which is very useful for testing. The CPU_Fatal_halt handler was split up into two, since the only the LEON3 support the CPU power down. The LEON3 halt now uses the power-down instruction to save CPU power. This doesn't stop a potential watch-dog timer from expiring.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon2/configure.ac')
-rw-r--r--c/src/lib/libbsp/sparc/leon2/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sparc/leon2/configure.ac b/c/src/lib/libbsp/sparc/leon2/configure.ac
index 610a04909c..dd49a17487 100644
--- a/c/src/lib/libbsp/sparc/leon2/configure.ac
+++ b/c/src/lib/libbsp/sparc/leon2/configure.ac
@@ -36,6 +36,11 @@ RTEMS_BSPOPTS_HELP([SIMSPARC_FAST_IDLE],
time spent in the idle task is minimized. This significantly reduces
the wall time required to execute the RTEMS test suites.])
+RTEMS_BSPOPTS_SET([BSP_POWER_DOWN_AT_FATAL_HALT],[*],[])
+RTEMS_BSPOPTS_HELP([BSP_POWER_DOWN_AT_FATAL_HALT],
+[If defined, CPU is spinning on fatal exit. Otherwise generate system
+ error which will hand over to debugger, simulator, etc.])
+
RTEMS_BSP_CLEANUP_OPTIONS(0, 1, 1)
# Explicitly list all Makefiles here