summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon2/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2008-09-29 03:43:47 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2008-09-29 03:43:47 +0000
commite94666ddc5133b44923a1c3a2f1b21043e0c6fdd (patch)
treec6e9bbace29dbd4e769e30356820174cc9c1e770 /c/src/lib/libbsp/sparc/leon2/Makefile.am
parent2008-09-29 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-e94666ddc5133b44923a1c3a2f1b21043e0c6fdd.tar.bz2
2008-09-29 Ralf Corsépius <ralf.corsepius@rtems.org>
* Makefile.am: Move noinst_LIBRARIES = libbsp.a before its components.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon2/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon2/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/sparc/leon2/Makefile.am b/c/src/lib/libbsp/sparc/leon2/Makefile.am
index fb3e80d8b6..339c60f570 100644
--- a/c/src/lib/libbsp/sparc/leon2/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon2/Makefile.am
@@ -53,6 +53,8 @@ project_lib_DATA = start.$(OBJEXT)
dist_project_lib_DATA += startup/linkcmds
+noinst_LIBRARIES = libbsp.a
+
startup_SOURCES = ../../shared/bspclean.c ../../shared/bsplibc.c \
../../shared/bsppost.c ../../shared/bsppredriverhook.c \
../../sparc/shared/bspgetworkarea.c ../../sparc/shared/bspstart.c \
@@ -107,7 +109,6 @@ leon_open_eth_rel_CPPFLAGS += -D__INSIDE_RTEMS_BSD_TCPIP_STACK__
leon_open_eth_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
-noinst_LIBRARIES = libbsp.a
libbsp_a_SOURCES = $(startup_SOURCES) $(gnatsupp_SOURCES) $(console_SOURCES) \
$(clock_SOURCES) $(amba_SOURCES) $(pci_SOURCES) $(rasta_SOURCES) \
$(cchip_SOURCES) $(brm_SOURCES) $(can_SOURCES) $(spw_SOURCES) \