summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon2/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-10-11 12:54:50 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-10-11 12:54:50 +0000
commitdd7f59172c7bb3715fa4ff46862affdcf2ca3c52 (patch)
treee35f5890c8c545f3707ec5a3a4ca47d517e1a479 /c/src/lib/libbsp/sparc/leon2/Makefile.am
parent2007-10-11 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-dd7f59172c7bb3715fa4ff46862affdcf2ca3c52.tar.bz2
2007-10-11 Daniel Hellstrom <daniel@gaisler.com>
* Makefile.am, preinstall.am: Fixes bug in OC-CAN baud rate calculator. The BTR1 8-bit value was swapped.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon2/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon2/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sparc/leon2/Makefile.am b/c/src/lib/libbsp/sparc/leon2/Makefile.am
index 8dc30b1740..5a4c196f7e 100644
--- a/c/src/lib/libbsp/sparc/leon2/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon2/Makefile.am
@@ -114,6 +114,12 @@ uart_rel_SOURCES = ../../sparc/shared/uart/apbuart.c ../../sparc/shared/uart/apb
uart_rel_CPPFLAGS = $(AM_CPPFLAGS)
uart_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+# I2CMST
+include_HEADERS += ../../sparc/shared/include/i2cmst.h
+noinst_PROGRAMS += i2cmst.rel
+i2cmst_rel_SOURCES = ../../sparc/shared/i2c/i2cmst.c
+i2cmst_rel_CPPFLAGS = $(AM_CPPFLAGS)
+i2cmst_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
if HAS_NETWORKING
noinst_PROGRAMS += leon_smc91111.rel