summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon2/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-09-06 00:01:14 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-09-06 00:01:14 +0000
commit4d3933b3009639a1ee5488e5eef13331bfbd9a26 (patch)
tree77d2b66e6f88fadc896efb83a634d0674e97c498 /c/src/lib/libbsp/sparc/leon2/Makefile.am
parent2007-09-05 Daniel Hellstrom <daniel@gaisler.com> (diff)
downloadrtems-4d3933b3009639a1ee5488e5eef13331bfbd9a26.tar.bz2
2007-09-05 Daniel Hellstrom <daniel@gaisler.com>
* Makefile.am, preinstall.am: LEON3 AMBA PnP bus scanning moved to shared/amba/amba.c and shared/include/ambapp.h. The AMBA scanning was improved to take account for PnP info address translation. This is useful when scanning remote AMBA busses for example when a board connected with PCI has an AMBA bus that needs to be scanned, before the addresses was hard coded. Also, LEON2 now have AMBA PnP bus scanning support. By using the new AMBA scanning routines it is possible to isolate the AMBA scanning code to ambapp.c, however existing drivers should be updated to use them in order to save space.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon2/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon2/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/sparc/leon2/Makefile.am b/c/src/lib/libbsp/sparc/leon2/Makefile.am
index 6760fb218e..94c2f53c2b 100644
--- a/c/src/lib/libbsp/sparc/leon2/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon2/Makefile.am
@@ -11,6 +11,7 @@ dist_project_lib_DATA = bsp_specs
include_HEADERS = include/bsp.h
include_HEADERS += include/tm27.h
+include_HEADERS += ../../sparc/shared/include/ambapp.h
nodist_include_HEADERS = include/bspopts.h
DISTCLEANFILES = include/bspopts.h
@@ -56,6 +57,11 @@ clock_rel_SOURCES = clock/ckinit.c
clock_rel_CPPFLAGS = $(AM_CPPFLAGS)
clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+noinst_PROGRAMS += amba.rel
+amba_rel_SOURCES = ../../sparc/shared/amba/ambapp.c
+amba_rel_CPPFLAGS = $(AM_CPPFLAGS)
+amba_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
if HAS_NETWORKING
noinst_PROGRAMS += leon_smc91111.rel
leon_smc91111_rel_SOURCES = leon_smc91111/leon_smc91111.c
@@ -79,7 +85,8 @@ endif
noinst_LIBRARIES = libbsp.a
libbsp_a_SOURCES =
-libbsp_a_LIBADD = startup.rel console.rel clock.rel timer.rel gnatsupp.rel
+libbsp_a_LIBADD = startup.rel console.rel clock.rel timer.rel gnatsupp.rel \
+ amba.rel
if HAS_NETWORKING
libbsp_a_LIBADD += leon_open_eth.rel