summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/erc32/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 13:59:35 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 13:59:35 +0000
commit1072609587a7f1a877a8e059c7158045d19034f5 (patch)
tree1a2490dd280b4670d68dc4e2ab6658e449e7421d /c/src/lib/libbsp/sparc/erc32/include/Makefile.am
parentPatch rtems-rc-20000104-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-1072609587a7f1a877a8e059c7158045d19034f5.tar.bz2
Patch rtems-rc-20000104-3.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts the sparc directory to automake. Ralf's note: The implementation of libbsp/sparc/* gives a nearly minimal example of the new configuration scheme.
Diffstat (limited to 'c/src/lib/libbsp/sparc/erc32/include/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/erc32/include/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sparc/erc32/include/Makefile.am b/c/src/lib/libbsp/sparc/erc32/include/Makefile.am
new file mode 100644
index 0000000000..fd65550e77
--- /dev/null
+++ b/c/src/lib/libbsp/sparc/erc32/include/Makefile.am
@@ -0,0 +1,20 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = bsp.h coverhd.h
+noinst_HEADERS = $(H_FILES)
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE) $(H_FILES:%.h=$(PROJECT_INCLUDE)/%.h)
+
+$(PROJECT_INCLUDE):
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am