summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/erc32/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-05-15 15:53:19 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-05-15 15:53:19 +0000
commit5e5d0b16ed1ad8b79ad235bfe72c9ad8d980a415 (patch)
treeebd4364951237e114a98097cf9487ae4dd810c7b /c/src/lib/libbsp/sparc/erc32/Makefile.am
parent2008-05-15 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-5e5d0b16ed1ad8b79ad235bfe72c9ad8d980a415.tar.bz2
2008-05-15 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: Add capability for bootcard.c BSP Initialization Framework to ask the BSP where it has memory for the RTEMS Workspace and C Program Heap. These collectively are referred to as work area. If the BSP supports this, then it does not have to include code to split the available memory between the two areas. This reduces the amount of code in the BSP specific bspstart.c file. Additionally, the shared framework can initialize the C Library, call rtems_debug_enable(), and dirty the work area memory. Until most/all BSPs support this new capability, if the BSP supports this, it should call RTEMS_BSP_BOOTCARD_HANDLES_RAM_ALLOCATION from its configure.ac. When the transition is complete, this autoconf macro can be removed.
Diffstat (limited to 'c/src/lib/libbsp/sparc/erc32/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/erc32/Makefile.am61
1 files changed, 12 insertions, 49 deletions
diff --git a/c/src/lib/libbsp/sparc/erc32/Makefile.am b/c/src/lib/libbsp/sparc/erc32/Makefile.am
index dd3627ce45..286ef70dcc 100644
--- a/c/src/lib/libbsp/sparc/erc32/Makefile.am
+++ b/c/src/lib/libbsp/sparc/erc32/Makefile.am
@@ -29,39 +29,16 @@ project_lib_DATA = start.$(OBJEXT)
dist_project_lib_DATA += startup/linkcmds
-noinst_PROGRAMS += startup.rel
-startup_rel_SOURCES = ../../sparc/shared/bspclean.c ../../shared/bsplibc.c \
+startup_SOURCES = ../../sparc/shared/bspclean.c ../../shared/bsplibc.c \
../../shared/bsppredriverhook.c \
../../shared/bsppost.c ../../sparc/shared/bspstart.c \
../../shared/bootcard.c ../../shared/sbrk.c startup/setvec.c \
startup/spurious.c startup/erc32mec.c startup/boardinit.S
-startup_rel_CPPFLAGS = $(AM_CPPFLAGS)
-startup_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_PROGRAMS += gnatsupp.rel
-gnatsupp_rel_SOURCES = gnatsupp/gnatsupp.c ../../sparc/shared/gnatcommon.c
-gnatsupp_rel_CPPFLAGS = $(AM_CPPFLAGS)
-gnatsupp_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_PROGRAMS += console.rel
-console_rel_SOURCES = console/console.c
-console_rel_CPPFLAGS = $(AM_CPPFLAGS)
-console_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_PROGRAMS += debugio.rel
-debugio_rel_SOURCES = console/debugputs.c
-debugio_rel_CPPFLAGS = $(AM_CPPFLAGS)
-debugio_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_PROGRAMS += clock.rel
-clock_rel_SOURCES = clock/ckinit.c
-clock_rel_CPPFLAGS = $(AM_CPPFLAGS)
-clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_PROGRAMS += timer.rel
-timer_rel_SOURCES = timer/timer.c
-timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
-timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+gnatsupp_SOURCES = gnatsupp/gnatsupp.c ../../sparc/shared/gnatcommon.c
+console_SOURCES = console/console.c
+debugio_SOURCES = console/debugputs.c
+clock_SOURCES = clock/ckinit.c
+timer_SOURCES = timer/timer.c
if HAS_NETWORKING
erc32sonic_CPPFLAGS = -D__INSIDE_RTEMS_BSD_TCPIP_STACK__
@@ -72,29 +49,15 @@ erc32sonic_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
noinst_LIBRARIES = libbsp.a
-libbsp_a_SOURCES =
-libbsp_a_LIBADD = console.rel clock.rel timer.rel gnatsupp.rel \
- debugio.rel
-if HAS_NETWORKING
-libbsp_a_LIBADD += erc32sonic.rel
-endif
+libbsp_a_SOURCES = $(startup_SOURCES) $(gnatsupp_SOURCES) $(console_SOURCES) \
+ $(debugio_SOURCES) $(clock_SOURCES) $(timer_SOURCES)
-libbsp_a_LIBADD += \
-startup_rel-boardinit.o \
-startup_rel-bootcard.o \
-startup_rel-bspclean.o \
-startup_rel-bsplibc.o \
-startup_rel-bsppost.o \
-startup_rel-bsppredriverhook.o \
-startup_rel-bspstart.o \
-startup_rel-erc32mec.o \
-startup_rel-sbrk.o \
-startup_rel-setvec.o \
-startup_rel-spurious.o
-
-libbsp_a_LIBADD += ../../../libcpu/@RTEMS_CPU@/cache.rel \
+libbsp_a_LIBADD = ../../../libcpu/@RTEMS_CPU@/cache.rel \
../../../libcpu/@RTEMS_CPU@/reg_win.rel \
../../../libcpu/@RTEMS_CPU@/syscall.rel
+if HAS_NETWORKING
+libbsp_a_LIBADD += erc32sonic.rel
+endif
EXTRA_DIST += times