summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/simsh4/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-29 12:24:44 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-29 12:24:44 +0000
commitac2be67747af19b74d50710ad565ea756da25935 (patch)
tree33bbe53ed7dce2e61b3c5b27369cb0d757cc0a20 /c/src/lib/libbsp/sh/simsh4/startup/Makefile.am
parentRemove unnecessary .cvsignore (diff)
downloadrtems-ac2be67747af19b74d50710ad565ea756da25935.tar.bz2
2004-01-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in clock/Makefile.am, console/Makefile.am, startup/Makefile.am, timer/Makefile.am, wrapup/Makefile.am. Use automake compilation rules. * clock/Makefile.am, console/Makefile.am, startup/Makefile.am, timer/Makefile.am, wrapup/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/sh/simsh4/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/simsh4/startup/Makefile.am52
1 files changed, 0 insertions, 52 deletions
diff --git a/c/src/lib/libbsp/sh/simsh4/startup/Makefile.am b/c/src/lib/libbsp/sh/simsh4/startup/Makefile.am
deleted file mode 100644
index c5d409afc1..0000000000
--- a/c/src/lib/libbsp/sh/simsh4/startup/Makefile.am
+++ /dev/null
@@ -1,52 +0,0 @@
-##
-## $Id$
-##
-
-VPATH = @srcdir@:@srcdir@/../../shared:@srcdir@/../../../shared
-
-PGM = $(ARCH)/startup.rel
-
-C_FILES = hw_init.c bsplibc.c bsppost.c bspstart.c bspclean.c sbrk.c \
- bootcard.c main.c gnatinstallhandler.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-OBJS = $(C_O_FILES)
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-project_lib_DATA = linkcmds linkcmds-le linkcmds-le.coff
-
-$(PGM): $(OBJS)
- $(make-rel)
-
-all-local: $(TMPINSTALL_FILES) $(PGM)
-
-EXTRA_DIST = bspstart.c hw_init.c linkcmds linkcmds-le linkcmds-le.coff
-
-TMPINSTALL_FILES =
-
-$(PROJECT_LIB)/$(dirstamp):
- @$(mkdir_p) $(PROJECT_LIB)
- @: > $(PROJECT_LIB)/$(dirstamp)
-TMPINSTALL_FILES += $(PROJECT_LIB)/$(dirstamp)
-
-$(PROJECT_LIB)/linkcmds: linkcmds $(PROJECT_LIB)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds
-TMPINSTALL_FILES += $(PROJECT_LIB)/linkcmds
-
-$(PROJECT_LIB)/linkcmds-le: linkcmds-le $(PROJECT_LIB)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds-le
-TMPINSTALL_FILES += $(PROJECT_LIB)/linkcmds-le
-
-$(PROJECT_LIB)/linkcmds-le.coff: linkcmds-le.coff $(PROJECT_LIB)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds-le.coff
-TMPINSTALL_FILES += $(PROJECT_LIB)/linkcmds-le.coff
-
-CLEANFILES = $(TMPINSTALL_FILES)
-
-include $(top_srcdir)/../../../../automake/local.am