summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/simsh4/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-11 04:09:26 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-11 04:09:26 +0000
commit758629c23cb22d5044bf52a21fd123999dc63598 (patch)
tree75ef6ba3e9741e45a2c34b4524d1c6fb14fee759 /c/src/lib/libbsp/sh/simsh4/startup/Makefile.am
parent2003-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-758629c23cb22d5044bf52a21fd123999dc63598.tar.bz2
2003-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* clock/Makefile.am: Misc cleanups and fixes. * start/Makefile.am: Misc cleanups and fixes. * startup/Makefile.am: Misc cleanups and fixes. * timer/Makefile.am: Misc cleanups and fixes.
Diffstat (limited to 'c/src/lib/libbsp/sh/simsh4/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/simsh4/startup/Makefile.am31
1 files changed, 14 insertions, 17 deletions
diff --git a/c/src/lib/libbsp/sh/simsh4/startup/Makefile.am b/c/src/lib/libbsp/sh/simsh4/startup/Makefile.am
index 2772f2f111..3fe2801789 100644
--- a/c/src/lib/libbsp/sh/simsh4/startup/Makefile.am
+++ b/c/src/lib/libbsp/sh/simsh4/startup/Makefile.am
@@ -19,29 +19,26 @@ include $(top_srcdir)/../../../../automake/lib.am
# (OPTIONAL) Add local stuff here using +=
#
-bsplib_DATA = linkcmds linkcmds-le linkcmds-le.coff
-
-$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_RELEASE)/lib/linkcmds-le: linkcmds-le
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_RELEASE)/lib/linkcmds-le.coff: linkcmds-le.coff
- $(INSTALL_DATA) $< $@
+project_lib_DATA = linkcmds linkcmds-le linkcmds-le.coff
$(PGM): $(OBJS)
$(make-rel)
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds \
- $(PROJECT_RELEASE)/lib/linkcmds-le \
- $(PROJECT_RELEASE)/lib/linkcmds-le.coff
-
-all-local: $(TMPINSTALL_FILES) $(OBJS) $(PGM)
-
-.PRECIOUS: $(PGM)
+all-local: $(TMPINSTALL_FILES) $(PGM)
EXTRA_DIST = bspclean.c bspstart.c hw_init.c linkcmds linkcmds-le \
linkcmds-le.coff
+${PROJECT_RELEASE}/lib/linkcmds: linkcmds ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds
+
+${PROJECT_RELEASE}/lib/linkcmds-le: linkcmds-le ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds-le
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds-le
+
+${PROJECT_RELEASE}/lib/linkcmds-le.coff: linkcmds-le.coff ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds-le.coff
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds-le.coff
+
include $(top_srcdir)/../../../../automake/local.am