summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/shsim/trap34/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-01-29 15:33:34 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-01-29 15:33:34 +0000
commite0ddaa7ee3f9e7162de820aa4e6efc3976bd2db7 (patch)
treef57671b575c79921d348350f4796f76b29f1ce14 /c/src/lib/libbsp/sh/shsim/trap34/Makefile.am
parent2001-01-26 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e0ddaa7ee3f9e7162de820aa4e6efc3976bd2db7.tar.bz2
2001-01-26 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* gdbsci/, scitab/, trap34/: Add directories.
Diffstat (limited to 'c/src/lib/libbsp/sh/shsim/trap34/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/shsim/trap34/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sh/shsim/trap34/Makefile.am b/c/src/lib/libbsp/sh/shsim/trap34/Makefile.am
new file mode 100644
index 0000000000..fc6f48e384
--- /dev/null
+++ b/c/src/lib/libbsp/sh/shsim/trap34/Makefile.am
@@ -0,0 +1,38 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+VPATH = @srcdir@:@srcdir@/../../../shared
+
+PGM = $(ARCH)/console.rel
+
+C_FILES = console-io.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+S_FILES = console-support.S
+S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES) $(S_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(OBJS)
+ $(make-rel)
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = console.c
+
+include $(top_srcdir)/../../../../../../automake/local.am