summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/shsim/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-15 19:18:31 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-15 19:18:31 +0000
commit512d0fcba10b84737fbaca5dd078995000667120 (patch)
tree672cf547719761f6016854ba3cdf72d541c18d62 /c/src/lib/libbsp/sh/shsim/configure.ac
parent2008-09-15 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-512d0fcba10b84737fbaca5dd078995000667120.tar.bz2
2008-09-15 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, include/bsp.h, startup/linkcmds: Use shared bsp_get_work_area() in its own file and rely on BSP Framework to perform more initialization. After factoring this out, it turned out that all SuperH BSPs has the same bsp_start() implementation so this was made shared.
Diffstat (limited to 'c/src/lib/libbsp/sh/shsim/configure.ac')
-rw-r--r--c/src/lib/libbsp/sh/shsim/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sh/shsim/configure.ac b/c/src/lib/libbsp/sh/shsim/configure.ac
index 06789a2d9a..fcf0563346 100644
--- a/c/src/lib/libbsp/sh/shsim/configure.ac
+++ b/c/src/lib/libbsp/sh/shsim/configure.ac
@@ -61,9 +61,16 @@ RTEMS_BSPOPTS_SET([CPU_CLOCK_RATE_HZ],[*],[20000000])
RTEMS_BSPOPTS_HELP([CPU_CLOCK_RATE_HZ],
[cpu clock rate in HZ])
+RTEMS_BSPOPTS_SET([START_HW_INIT],[*],[])
+RTEMS_BSPOPTS_HELP([START_HW_INIT],
+[If defined, selects whether 'early_hw_init()' is called from 'start.S';
+ 'bsp_hw_init()' is always called from 'bspstart.c'])
+
## Used in scitab/Makefile.am
AC_SUBST(CPU_CLOCK_RATE_HZ)
+RTEMS_BSP_BOOTCARD_HANDLES_RAM_ALLOCATION
+
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile])
AC_OUTPUT