summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh4/console/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-15 18:01:50 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-15 18:01:50 +0000
commit6ce599cdf62258ce2eaf7a2a9c9c3407cf74cee3 (patch)
treedfe1a4bc2745cf2b2d58c381ce421fdd6caa1205 /c/src/lib/libbsp/sh/gensh4/console/Makefile.am
parent2001-10-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-6ce599cdf62258ce2eaf7a2a9c9c3407cf74cee3.tar.bz2
2001-10-13 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Remove AC_SUBST(CPU_CLOCK_RATE_HZ), add START_HW_INIT-support macros, add console/Makefile. * Makefile.am: Add console SUBDIR. * hw_init/Makefile.am: Fix C_FILES, remove AM_CPPFLAGS/HZ. * include/Makefile.am: Add bspopts.h. * include/bsp.h: Comment out SH4_CPU_HZ_Frequency. * startup/bspstart.c: Comment out SH4_CPU_HZ_Frequency. * startup/linkcmds: Comment out OUTPUT_FORMAT for coff compatibility. * wrapup/Makefile.am: Add console to BSP_PIECES. * console/Makefile.am: New. * console/console.c: Moved from libcpu/sh/sh7750/sci/console.c.
Diffstat (limited to 'c/src/lib/libbsp/sh/gensh4/console/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/gensh4/console/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sh/gensh4/console/Makefile.am b/c/src/lib/libbsp/sh/gensh4/console/Makefile.am
new file mode 100644
index 0000000000..81c2d41de8
--- /dev/null
+++ b/c/src/lib/libbsp/sh/gensh4/console/Makefile.am
@@ -0,0 +1,32 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = $(ARCH)/console.rel
+
+C_FILES = console.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(OBJS)
+ $(make-rel)
+
+# the .rel file built here will be put into libbsp.a by
+# ../wrapup/Makefile
+
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+include $(top_srcdir)/../../../../../../automake/local.am