summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh4/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-15 19:18:29 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-15 19:18:29 +0000
commit11a6c974621241c2d556112fe62700b7dd355b5b (patch)
tree9a794ce5e1eae9bb0fd93e995922057b6748f8a5 /c/src/lib/libbsp/sh/gensh4/Makefile.am
parent2008-09-15 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-11a6c974621241c2d556112fe62700b7dd355b5b.tar.bz2
2008-09-15 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, include/bsp.h, startup/linkcmds: Use shared bsp_get_work_area() in its own file and rely on BSP Framework to perform more initialization. After factoring this out, it turned out that all SuperH BSPs has the same bsp_start() implementation so this was made shared. * startup/bspstart.c: Removed.
Diffstat (limited to 'c/src/lib/libbsp/sh/gensh4/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/gensh4/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/sh/gensh4/Makefile.am b/c/src/lib/libbsp/sh/gensh4/Makefile.am
index ebe7d882cc..08201be6d6 100644
--- a/c/src/lib/libbsp/sh/gensh4/Makefile.am
+++ b/c/src/lib/libbsp/sh/gensh4/Makefile.am
@@ -29,9 +29,10 @@ dist_project_lib_DATA += startup/linkcmds startup/linkcmds.rom \
startup/linkcmds.rom2ram
startup_SOURCES = ../../shared/bsplibc.c ../../shared/bsppost.c \
- ../../shared/bsppredriverhook.c startup/bspstart.c \
+ ../../shared/bsppredriverhook.c ../shared/bspstart.c \
+ ../../shared/bsppretaskinghook.c ../shared/bspgetworkarea.c \
../../shared/bspclean.c ../../shared/sbrk.c ../../shared/bootcard.c \
- ../../shared/gnatinstallhandler.c
+ ../../shared/gnatinstallhandler.c ../shared/bsphwinit.c
console_SOURCES = console/console.c ../../shared/dummy_printk_support.c
hw_init_SOURCES = hw_init/hw_init.c