summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh2/start/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
commit4e36a2f133c68aaf637e166385eff1a05b59f38e (patch)
tree47520e4fbb8b685c25ae2909cf2a12287be4268b /c/src/lib/libbsp/sh/gensh2/start/Makefile.am
parentPatch rtems-rc-20000118-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4e36a2f133c68aaf637e166385eff1a05b59f38e.tar.bz2
Patches rtems-rc-20000118-3.diff and rtems-rc-20000118-4.diff from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> that contain: * Modifications, (minor) corrections, cleanups to most existing Makefile.ams * Adds automake support to all remaining BSPs which have not yet been converted to automake. * Makefile.am for all remaining wrapup/Makefile.ams
Diffstat (limited to 'c/src/lib/libbsp/sh/gensh2/start/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/gensh2/start/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/c/src/lib/libbsp/sh/gensh2/start/Makefile.am b/c/src/lib/libbsp/sh/gensh2/start/Makefile.am
index f6aeba8911..cab0be15ab 100644
--- a/c/src/lib/libbsp/sh/gensh2/start/Makefile.am
+++ b/c/src/lib/libbsp/sh/gensh2/start/Makefile.am
@@ -4,11 +4,10 @@
AUTOMAKE_OPTIONS = foreign 1.4
-PGMS = ${ARCH}/start.o
+PGMS = $(ARCH)/start.o
-## Assembly source names
S_FILES = start.S
-S_O_FILES = $(S_FILES:%.S=${ARCH}/%.o)
+S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
OBJS = $(S_O_FILES)
@@ -19,9 +18,13 @@ include $(top_srcdir)/../../../../../../automake/lib.am
# (OPTIONAL) Add local stuff here using +=
#
-all-local: ${ARCH} $(OBJS)
- @$(INSTALL_VARIANT) -m 755 ${PGMS} $(PROJECT_RELEASE)/lib
+$(PROJECT_RELEASE)/lib/start$(LIB_VARIANT).o: $(PGMS)
+ $(INSTALL_DATA) $< $@
-EXTRA_DIST = $(S_FILES)
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/start$(LIB_VARIANT).o
+
+all-local: $(ARCH) $(OBJS) $(TMPINSTALL_FILES)
+
+EXTRA_DIST = start.S start.ram start.rom
include $(top_srcdir)/../../../../../../automake/local.am