summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh2/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2008-09-30 07:12:11 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2008-09-30 07:12:11 +0000
commit57a40406666d93e6219b5a33a99e56adeb342d11 (patch)
treef6f4ebdd349dee80781e27b76907f540d596ff15 /c/src/lib/libbsp/sh/gensh2/Makefile.am
parent2008-09-30 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-57a40406666d93e6219b5a33a99e56adeb342d11.tar.bz2
2008-09-30 Ralf Corsépius <ralf.corsepius@rtems.org>
* Makefile.am: Eliminate bsp.am. Build startup files as side-effect of building libbspstart.a, using automake-rules.
Diffstat (limited to 'c/src/lib/libbsp/sh/gensh2/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/gensh2/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/c/src/lib/libbsp/sh/gensh2/Makefile.am b/c/src/lib/libbsp/sh/gensh2/Makefile.am
index 1003189e41..c7f466bf47 100644
--- a/c/src/lib/libbsp/sh/gensh2/Makefile.am
+++ b/c/src/lib/libbsp/sh/gensh2/Makefile.am
@@ -5,7 +5,6 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../bsp.am
include_bspdir = $(includedir)/bsp
@@ -20,15 +19,15 @@ DISTCLEANFILES = include/bspopts.h
include_HEADERS += include/coverhd.h
-EXTRA_DIST = start/start.S start/start.ram start/start.rom
-start.$(OBJEXT): start/start.S
- $(CPPASCOMPILE) -o $@ -c $<
+EXTRA_DIST = start/start.ram start/start.rom
+noinst_LIBRARIES = libbspstart.a
+libbspstart_a_SOURCES = start/start.S
project_lib_DATA = start.$(OBJEXT)
dist_project_lib_DATA += startup/linkcmds startup/linkcmds.ram \
startup/linkcmds.rom
-noinst_LIBRARIES = libbsp.a
+noinst_LIBRARIES += libbsp.a
libbsp_a_SOURCES =
SHGEN = $(PROJECT_TOPdir)/tools/cpu/sh/shgen