summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh1/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-06-06 16:21:22 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-06-11 14:47:32 +0200
commit8c62cf4209b2fe57fdbc3a138f2c644e19774367 (patch)
tree1b2ccf4bb0f27934d31cd856c48994a295ffdd0c /c/src/lib/libbsp/sh/gensh1/configure.ac
parentbuild: Force warnings (diff)
downloadrtems-8c62cf4209b2fe57fdbc3a138f2c644e19774367.tar.bz2
tools: Remove shgen
All tools should be removed from the RTEMS source repository at some point in time. Tools with a BSD-style license will be moved to the RTEMS tools repository. Unfortunately, the shgen tool is GPL licensed. Remove all uses of this tool from the code base. Replace generated files with stub functions. If users of this BSP still exist, they can reimplement the functionality using a BSD-style license. Close #3443.
Diffstat (limited to 'c/src/lib/libbsp/sh/gensh1/configure.ac')
-rw-r--r--c/src/lib/libbsp/sh/gensh1/configure.ac7
1 files changed, 1 insertions, 6 deletions
diff --git a/c/src/lib/libbsp/sh/gensh1/configure.ac b/c/src/lib/libbsp/sh/gensh1/configure.ac
index 44b2e047eb..d336f9e094 100644
--- a/c/src/lib/libbsp/sh/gensh1/configure.ac
+++ b/c/src/lib/libbsp/sh/gensh1/configure.ac
@@ -13,17 +13,12 @@ RTEMS_BSP_CONFIGURE
## bsp-specific options
-RTEMS_BSPOPTS_SET([CPU_CLOCK_RATE_HZ],[*],[20000000])
-RTEMS_BSPOPTS_HELP([CPU_CLOCK_RATE_HZ],[cpu clock rate in HZ])
-
RTEMS_BSPOPTS_SET([START_HW_INIT],[*],[])
RTEMS_BSPOPTS_HELP([START_HW_INIT],
[If defined, selects whether 'early_hw_init()' is called from 'start.S';
'bsp_hw_init()' is always called from 'bspstart.c'])
-## Used in scitab/Makefile.am
-AC_SUBST(CPU_CLOCK_RATE_HZ)
-
+AC_DEFINE(CPU_CLOCK_RATE_HZ, 20000000, [cpu clock rate in HZ])
RTEMS_BSP_CLEANUP_OPTIONS
# Explicitly list all Makefiles here