summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh1/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-05-14 16:42:14 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-05-14 16:42:14 +0000
commitd4d4c0510ba8213b42c266f96827230c1b4281dd (patch)
tree95cb91dbcdf9a086604cddec385987a8cc887293 /c/src/lib/libbsp/sh/gensh1/Makefile.am
parentNew (merge-in gcc-4.2.0 final patches). (diff)
downloadrtems-d4d4c0510ba8213b42c266f96827230c1b4281dd.tar.bz2
2007-05-14 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am: Separate debug IO from console so console driver is not linked in all the time. This manaifested itself when the IO manager optional manager stub dropped some symbols.
Diffstat (limited to 'c/src/lib/libbsp/sh/gensh1/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/gensh1/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/sh/gensh1/Makefile.am b/c/src/lib/libbsp/sh/gensh1/Makefile.am
index 857a8c7b55..542b4b0fb5 100644
--- a/c/src/lib/libbsp/sh/gensh1/Makefile.am
+++ b/c/src/lib/libbsp/sh/gensh1/Makefile.am
@@ -47,15 +47,19 @@ scitab_rel_SOURCES = scitab.c
scitab_rel_CPPFLAGS = $(AM_CPPFLAGS)
scitab_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+noinst_PROGRAMS += debugio.rel
+debugio_rel_SOURCES = ../../shared/dummy_printk_support.c
+debugio_rel_CPPFLAGS = $(AM_CPPFLAGS)
+debugio_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
noinst_PROGRAMS += console.rel
-console_rel_SOURCES = ../../sh/shared/console.c \
- ../../shared/dummy_printk_support.c
+console_rel_SOURCES = ../../sh/shared/console.c
console_rel_CPPFLAGS = $(AM_CPPFLAGS)
console_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
noinst_LIBRARIES = libbsp.a
libbsp_a_SOURCES =
-libbsp_a_LIBADD = startup.rel scitab.rel console.rel
+libbsp_a_LIBADD = startup.rel scitab.rel console.rel debugio.rel
libbsp_a_LIBADD += ../../../libcpu/@RTEMS_CPU@/@RTEMS_CPU_MODEL@/clock.rel \
../../../libcpu/@RTEMS_CPU@/@RTEMS_CPU_MODEL@/timer.rel \
../../../libcpu/@RTEMS_CPU@/@RTEMS_CPU_MODEL@/sci.rel \