summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/riscv/griscv/Makefile.am
diff options
context:
space:
mode:
authorHesham Almatary <Hesham.Almatary@cl.cam.ac.uk>2019-10-23 12:43:17 +0100
committerHesham Almatary <Hesham.Almatary@cl.cam.ac.uk>2019-10-27 10:45:00 +0000
commitf462bcbb0a2cf6030bf2420aae0e083856bf3a53 (patch)
treefa790631c01d2690abf438634dcb596eedc408fc /c/src/lib/libbsp/riscv/griscv/Makefile.am
parentriscv: Generate linkcmds.base from the shared linkcmds.base.in (diff)
downloadrtems-f462bcbb0a2cf6030bf2420aae0e083856bf3a53.tar.bz2
riscv: Address differences in the linkerscript between GNU LD and LLVM/LLD
LLVM/LLD does not support STARTUP and ALIGN_WITH_INPUT directives that GNU LD support. INPUT and ALIGN(8) are supported by LLVM/LLD and can replace the unsupported STARTUP/ALIGN_WITH_INPUT directives. The commit conditionally adds the supported directive that linkers can understand depending on the toolchain used to compile RTEMS i.e., clang or gcc. Clang is assumed to use LLD by default.
Diffstat (limited to 'c/src/lib/libbsp/riscv/griscv/Makefile.am')
-rw-r--r--c/src/lib/libbsp/riscv/griscv/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/riscv/griscv/Makefile.am b/c/src/lib/libbsp/riscv/griscv/Makefile.am
index 4077ddebd2..e04598e4bf 100644
--- a/c/src/lib/libbsp/riscv/griscv/Makefile.am
+++ b/c/src/lib/libbsp/riscv/griscv/Makefile.am
@@ -23,7 +23,7 @@ start.$(OBJEXT): ../../../../../../bsps/riscv/shared/start/start.S
project_lib_DATA = start.$(OBJEXT)
project_lib_DATA += linkcmds
-project_lib_DATA += ../../../../../../bsps/riscv/shared/start/linkcmds.base
+project_lib_DATA += linkcmds.base
###############################################################################
# LibBSP #