summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/tqm8xx/configure.ac
diff options
context:
space:
mode:
authorThomas Doerfler <Thomas.Doerfler@embedded-brains.de>2010-01-19 09:11:34 +0000
committerThomas Doerfler <Thomas.Doerfler@embedded-brains.de>2010-01-19 09:11:34 +0000
commitde592aa6f1a466df53a687173918f2e24a54a925 (patch)
treead5a0d3da8d59ba0ab2a2ce34a14ac041b46e43a /c/src/lib/libbsp/powerpc/tqm8xx/configure.ac
parentUpdate for block device API change. (diff)
downloadrtems-de592aa6f1a466df53a687173918f2e24a54a925.tar.bz2
tqm8xx BSP fixes
Diffstat (limited to 'c/src/lib/libbsp/powerpc/tqm8xx/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/tqm8xx/configure.ac20
1 files changed, 19 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/powerpc/tqm8xx/configure.ac b/c/src/lib/libbsp/powerpc/tqm8xx/configure.ac
index d989356eb6..a72893cffc 100644
--- a/c/src/lib/libbsp/powerpc/tqm8xx/configure.ac
+++ b/c/src/lib/libbsp/powerpc/tqm8xx/configure.ac
@@ -51,7 +51,7 @@ RTEMS_BSPOPTS_HELP([PRINTK_CHN],
each other.])
RTEMS_BSPOPTS_SET([CONS_SMC1_MODE],[tqm8xx_stk8xx],[CONS_MODE_POLLED])
-RTEMS_BSPOPTS_SET([CONS_SMC1_MODE],[pghplus],[CONS_MODE_POLLED])
+RTEMS_BSPOPTS_SET([CONS_SMC1_MODE],[pghplus],[CONS_MODE_IRQ])
RTEMS_BSPOPTS_SET([CONS_SMC1_MODE],[*],[CONS_MODE_UNUSED])
RTEMS_BSPOPTS_HELP([CONS_SMC1_MODE],
[(BSP--SMC1 UART IF mode) Must be defined if SMC1 is used as a tty (UART)
@@ -89,6 +89,24 @@ RTEMS_BSPOPTS_HELP([CONS_SCC4_MODE],
channel. Set it to CONS_MODE_POLLED for polled operation, CONS_MODE_IRQ for
interrupt driven (spooled) operation. Set it to CONS_MODE_UNUSED, if not used])
+RTEMS_BSPOPTS_SET([SPI_BOARD_INIT_FNC],[pghplus],[bsp_pghplus_spi_init])
+RTEMS_BSPOPTS_SET([SPI_BOARD_INIT_FNC],[*],[bsp_dummy_spi_init])
+RTEMS_BSPOPTS_HELP([SPI_BOARD_INIT_FNC],
+[(BSP--SPI board init function) Specify the function that inits the board
+ port lines and further devices.])
+
+RTEMS_BSPOPTS_SET([SPI_SEND_STOP_FNC],[pghplus],[bsp_pghplus_spi_send_stop])
+RTEMS_BSPOPTS_SET([SPI_SEND_STOP_FNC],[*],[bsp_dummy_spi_send_stop])
+RTEMS_BSPOPTS_HELP([SPI_SEND_STOP_FNC],
+[(BSP--SPI send stop function) Specify the function that deaddresses SPI
+ devices. Set to bsp_dummy_spi_send_stop for dummy implementation])
+
+RTEMS_BSPOPTS_SET([SPI_SEND_ADDR_FNC],[pghplus],[bsp_pghplus_spi_sel_addr])
+RTEMS_BSPOPTS_SET([SPI_SEND_ADDR_FNC],[*],[bsp_dummy_spi_sel_addr])
+RTEMS_BSPOPTS_HELP([SPI_SEND_ADDR_FNC],
+[(BSP--SPI send address function) Specify the function that addresses SPI
+ devices. Set to bsp_dummy_spi_sel_addr for dummy implementation])
+
# add selection of primary network interface
RTEMS_BSPOPTS_SET([BSP_USE_NETWORK_FEC],[pghplus],[1])
RTEMS_BSPOPTS_SET([BSP_USE_NETWORK_FEC],[*],[0])