summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/t32mppc/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2012-05-21 14:56:31 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2012-05-22 15:05:22 +0200
commite21c287cdb7c00a55e232b501f1f20d61bb85f83 (patch)
tree0ae391a56ba3210ad7ab8022f577b2eda62b00c1 /c/src/lib/libbsp/powerpc/t32mppc/configure.ac
parentnetwork/dhcp: PR1841: Fix DNS processing in DHCP (diff)
downloadrtems-e21c287cdb7c00a55e232b501f1f20d61bb85f83.tar.bz2
powerpc/t32mppc: New BSP
Diffstat (limited to 'c/src/lib/libbsp/powerpc/t32mppc/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/t32mppc/configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/t32mppc/configure.ac b/c/src/lib/libbsp/powerpc/t32mppc/configure.ac
new file mode 100644
index 0000000000..85b0f2b8ce
--- /dev/null
+++ b/c/src/lib/libbsp/powerpc/t32mppc/configure.ac
@@ -0,0 +1,28 @@
+AC_PREREQ(2.60)
+AC_INIT([rtems-c-src-lib-libbsp-powerpc-qoriq],[_RTEMS_VERSION],[http://www.rtems.org/bugzilla])
+AC_CONFIG_SRCDIR([bsp_specs])
+RTEMS_TOP(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE([no-define nostdinc foreign 1.10])
+RTEMS_BSP_CONFIGURE
+
+RTEMS_PROG_CC_FOR_TARGET
+RTEMS_CANONICALIZE_TOOLS
+RTEMS_PROG_CCAS
+
+RTEMS_BSPOPTS_SET_DATA_CACHE_ENABLED([*],[1])
+RTEMS_BSPOPTS_HELP_DATA_CACHE_ENABLED
+
+RTEMS_BSPOPTS_SET_INSTRUCTION_CACHE_ENABLED([*],[1])
+RTEMS_BSPOPTS_HELP_INSTRUCTION_CACHE_ENABLED
+
+RTEMS_CHECK_NETWORKING
+AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
+
+RTEMS_BSP_CLEANUP_OPTIONS(0, 0)
+RTEMS_PPC_EXCEPTIONS
+RTEMS_BSP_LINKCMDS
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT