summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/t32mppc/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-11-08 13:13:32 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-11-08 13:14:30 +0100
commit7078a00b13ab90fb39d6504a3bbeacd48b894752 (patch)
tree4edb5508ee6fc87274e68730fe5483114cabe31b /c/src/lib/libbsp/powerpc/t32mppc/configure.ac
parentbsp/imx: Add UART baud change (diff)
downloadrtems-7078a00b13ab90fb39d6504a3bbeacd48b894752.tar.bz2
bsp/t32mppc: Use fixed exception handlers
Diffstat (limited to 'c/src/lib/libbsp/powerpc/t32mppc/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/t32mppc/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/t32mppc/configure.ac b/c/src/lib/libbsp/powerpc/t32mppc/configure.ac
index fce295e9fd..ff50fe1a38 100644
--- a/c/src/lib/libbsp/powerpc/t32mppc/configure.ac
+++ b/c/src/lib/libbsp/powerpc/t32mppc/configure.ac
@@ -17,6 +17,14 @@ RTEMS_BSPOPTS_HELP_DATA_CACHE_ENABLED
RTEMS_BSPOPTS_SET_INSTRUCTION_CACHE_ENABLED([*],[1])
RTEMS_BSPOPTS_HELP_INSTRUCTION_CACHE_ENABLED
+RTEMS_BSPOPTS_SET([PPC_EXC_CONFIG_USE_FIXED_HANDLER],[*],[1])
+RTEMS_BSPOPTS_HELP([PPC_EXC_CONFIG_USE_FIXED_HANDLER],
+[use fixed high-level exception handler])
+
+RTEMS_BSPOPTS_SET([PPC_EXC_CONFIG_BOOKE_ONLY],[*],[1])
+RTEMS_BSPOPTS_HELP([PPC_EXC_CONFIG_BOOKE_ONLY],
+[only support Book E exception types])
+
RTEMS_CHECK_SMP
AM_CONDITIONAL(HAS_SMP,[test "$rtems_cv_HAS_SMP" = "yes"])