summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 12:54:49 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 12:54:49 +0000
commitd1b26aafd6dcabc888586be86db1e1adf9bb6f05 (patch)
treeddfbcef079c882ab203df59ec60861c796603b60 /c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am
parent2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-d1b26aafd6dcabc888586be86db1e1adf9bb6f05.tar.bz2
2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Add RTEMS_PROG_CCAS. * Makefile.am: Use automake compilation rules.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am30
1 files changed, 15 insertions, 15 deletions
diff --git a/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am b/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am
index 9bcad871b5..9c5b684b4e 100644
--- a/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am
@@ -4,26 +4,26 @@
ACLOCAL_AMFLAGS = -I ../../../../../aclocal
-C_FILES = cpu.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
-
-S_FILES = cpu_asm.S
-S_O_FILES = $(S_FILES:%.S=${ARCH}/%.$(OBJEXT))
-
include $(top_srcdir)/../../../../../automake/compile.am
-include $(top_srcdir)/../../../../../automake/lib.am
-#
-# (OPTIONAL) Add local stuff here using +=
-#
+EXTRA_PROGRAMS =
+CLEANFILES =
+noinst_DATA =
-REL = $(ARCH)/rtems-cpu.rel
+all-local: $(TMPINSTALL_FILES)
-$(REL): $(C_O_FILES) $(S_O_FILES)
- $(make-rel)
+EXTRA_PROGRAMS += rtems-cpu.rel
+CLEANFILES += rtems-cpu.rel
+rtems_cpu_rel_SOURCES = cpu.c cpu_asm.S
+rtems_cpu_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+rtems_cpu_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-all-local: $(TMPINSTALL_FILES) $(REL)
+EXTRA_PROGRAMS += rtems-cpu_g.rel
+CLEANFILES += rtems-cpu_g.rel
+rtems_cpu_g_rel_SOURCES = $(rtems_cpu_rel_SOURCES)
+rtems_cpu_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+rtems_cpu_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_DIST = $(C_FILES) $(S_FILES)
+noinst_DATA += rtems-cpu$(LIB_VARIANT).rel
include $(top_srcdir)/../../../../../automake/local.am