summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-11-28 18:15:51 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-11-28 18:15:51 +0000
commit75ad73760f33b0d2b30061919d8d4b4bf0b4277b (patch)
treefa1952b4f64567b4a808aa2c9dbb7d672f517c38 /c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am
parent2001-11-27 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-75ad73760f33b0d2b30061919d8d4b4bf0b4277b.tar.bz2
2001-11-28 Joel Sherrill <joel@OARcorp.com>,
This was tracked as PR91. * rtems/score/cpu.h: Added CPU_PROVIDES_ISR_IS_IN_PROGRESS macro which is used to specify if the port uses the standard macro for this (FALSE). A TRUE setting indicates the port provides its own implementation. * rtems/score/c_isr.inl: Deleted and contents merged into cpu.c. * cpu.c: Received contents of c_isr.inl. * Makefile.am: Deleted reference to c_isr.inl.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am b/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am
index 60b41ae61e..4fba2eabc5 100644
--- a/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/support/new_exception_processing/Makefile.am
@@ -11,7 +11,7 @@ C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
include_rtems_scoredir = $(includedir)/rtems/score
-include_rtems_score_HEADERS = rtems/score/cpu.h rtems/score/c_isr.inl
+include_rtems_score_HEADERS = rtems/score/cpu.h
S_FILES = cpu_asm.S
S_O_FILES = $(S_FILES:%.S=${ARCH}/%.o)
@@ -28,8 +28,7 @@ TMPINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/rtems/score \
$(include_rtems_score_HEADERS:%=$(PROJECT_INCLUDE)/%)
# FIXME: This should not be here.
-PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems/score/cpu.h \
- $(PROJECT_INCLUDE)/rtems/score/c_isr.inl
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems/score/cpu.h
$(PROJECT_INCLUDE):
$(mkinstalldirs) $@