summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/ss555/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2004-04-12 21:52:13 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2004-04-12 21:52:13 +0000
commita800d09cc79100fb8e10e10fa344c5218ce91d69 (patch)
tree353ae933c659bd80b1c37430448b2d8e3992b2cb /c/src/lib/libbsp/powerpc/ss555/configure.ac
parent2004-04-12 Ralf Corsepius <ralf_corsepius@rtems.org> (diff)
downloadrtems-a800d09cc79100fb8e10e10fa344c5218ce91d69.tar.bz2
2004-04-12 David Querbach <querbach@realtime.bc.ca>
* .cvsignore, ChangeLog, Makefile.am, README, bsp_specs, configure.ac, times, clock/p_clock.c, console/console.c, include/.cvsignore, include/bsp.h, include/coverhd.h, irq/irq.h, startup/bspstart.c, startup/iss555.c, startup/linkcmds, startup/start.S, wrapup/.cvsignore, wrapup/Makefile.am: New files.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/ss555/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/ss555/configure.ac53
1 files changed, 53 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/ss555/configure.ac b/c/src/lib/libbsp/powerpc/ss555/configure.ac
new file mode 100644
index 0000000000..5145fb0d33
--- /dev/null
+++ b/c/src/lib/libbsp/powerpc/ss555/configure.ac
@@ -0,0 +1,53 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ(2.59)
+AC_INIT([rtems-c-src-lib-libbsp-powerpc-mbx5xx],[_RTEMS_VERSION],[rtems-bugs@rtems.com])
+AC_CONFIG_SRCDIR([bsp_specs])
+RTEMS_TOP(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE([no-define nostdinc foreign 1.8])
+RTEMS_BSP_CONFIGURE
+
+RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
+RTEMS_CANONICALIZE_TOOLS
+RTEMS_PROG_CCAS
+
+RTEMS_CHECK_NETWORKING
+AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
+
+RTEMS_BSPOPTS_SET([WATCHDOG_TIMEOUT],[*],[0xFFFF])
+RTEMS_BSPOPTS_HELP([WATCHDOG_TIMEOUT],
+[Define to the desired timeout (in steps of 1/20 msec) to enable the
+ watchdog. Default is to disable the watchdog entirely.])
+
+RTEMS_BSPOPTS_SET([UARTS_USE_TERMIOS],[*],[0])
+RTEMS_BSPOPTS_HELP([UARTS_USE_TERMIOS],
+[Define to 1 if you want termios support for every port.
+ Termios support is independent of the choice of UART I/O mode.])
+
+RTEMS_BSPOPTS_SET([CONSOLE_MINOR],[*],[SCI2_MINOR])
+RTEMS_BSPOPTS_HELP([CONSOLE_MINOR],
+[Must be defined to be one of SCI1_MINOR or SCI2_MINOR. Determines which
+ device will be registered as /dev/console.])
+
+RTEMS_BSPOPTS_SET([UARTS_IO_MODE],[*],[0])
+RTEMS_BSPOPTS_HELP([UARTS_IO_MODE],
+[Define to 1 if you want interrupt-driven I/O for the SCI ports.])
+
+RTEMS_BSPOPTS_SET([PRINTK_MINOR],[*],[SCI2_MINOR])
+RTEMS_BSPOPTS_HELP([PRINTK_MINOR],
+[Must be defined to be one of SCI1_MINOR or SCI2_MINOR. Determines which
+ device is used for output by printk(). The printk port always uses polled
+ I/O. Don't open the printk port from RTEMS unless also using polled I/O
+ for the SCI ports.])
+
+# Explicitly list a Makefile here
+AC_CONFIG_FILES([Makefile
+wrapup/Makefile])
+
+RTEMS_PPC_EXCEPTIONS([new])
+
+AC_OUTPUT