summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/ss555/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2004-04-21 20:24:36 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2004-04-21 20:24:36 +0000
commit7312649847ee783fdb1a5330761696781ab22dc1 (patch)
treed3c86900efc1bd022d53a104cd75f9b028ce2292 /c/src/lib/libbsp/powerpc/ss555/Makefile.am
parent2004-04-21 Ralf Corsepius <ralf_corsepius@rtems.org> (diff)
downloadrtems-7312649847ee783fdb1a5330761696781ab22dc1.tar.bz2
2004-04-21 Joel Sherrill <joel@OARcorp.com>
PR 611/bsps * Makefile.am, include/bsp.h, wrapup/Makefile.am: Follow conventions for tm27 and do not add another macro definition. * startup/tm27supp.c: New file.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/ss555/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/ss555/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/ss555/Makefile.am b/c/src/lib/libbsp/powerpc/ss555/Makefile.am
index 5f8bc8429a..e69f505058 100644
--- a/c/src/lib/libbsp/powerpc/ss555/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/ss555/Makefile.am
@@ -74,6 +74,22 @@ startup_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
noinst_DATA += startup$(LIB_VARIANT).rel
+EXTRA_PROGRAMS += tm27supp.rel
+CLEANFILES += tm27supp.rel
+tm27supp_rel_SOURCES = startup/tm27supp.c
+tm27supp_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+tm27supp_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += tm27supp$(LIB_VARIANT).rel
+
+EXTRA_PROGRAMS += tm27supp_g.rel
+CLEANFILES += tm27supp_g.rel
+tm27supp_g_rel_SOURCES = $(tm27supp_rel_SOURCES)
+tm27supp_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+tm27supp_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += tm27supp$(LIB_VARIANT).rel
+
all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
PREINSTALL_DIRS =