summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/shared/start/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2003-03-18 19:20:55 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2003-03-18 19:20:55 +0000
commit64f8ae44ccb651e550fe5d7369feda6b3f21fcb6 (patch)
treeafd706051b15ea39a81e286f4c6642cd4dcb9510 /c/src/lib/libbsp/powerpc/shared/start/Makefile.am
parent2003-03-18 Till Straumann <strauman@slac.stanford.edu> (diff)
downloadrtems-64f8ae44ccb651e550fe5d7369feda6b3f21fcb6.tar.bz2
2003-03-18 Till Straumann <strauman@slac.stanford.edu>
PR 356/bsps This patch makes RTEMS/powerpc/shared EABI compliant. * irq/irq_init.c, start/Makefile.am, start/start.S, startup/bspstart.c, startup/pgtbl_setup.c, vectors/vectors.h, vectors/vectors_init.c: zero_bss() should clear not only bss but sbss and sbss2 also (this is probably a bugfix, as sbss/sbss2 are probably used even if -msdata=eabi is not specified). * start/rtems_crti.S: New file which must be linked immediately after ecrti.o. rtems_crti.o contains a code snippet who lets __init() return immediately. Also, a new entry point '_init' to the C++ Ctors is generated for use by the RTEMS Thread_Handler.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/shared/start/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/shared/start/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/powerpc/shared/start/Makefile.am b/c/src/lib/libbsp/powerpc/shared/start/Makefile.am
index 52836016ed..0ba9486deb 100644
--- a/c/src/lib/libbsp/powerpc/shared/start/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/shared/start/Makefile.am
@@ -3,8 +3,8 @@
##
-S_FILES = start.S
+S_FILES = start.S rtems_crti.S
-EXTRA_DIST = start.S
+EXTRA_DIST = start.S rtems_crti.S
include $(top_srcdir)/../../../../../automake/local.am