summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/shared/residual/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-02 11:24:16 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-02 11:24:16 +0000
commita77cd06666febd2e8f34cd7d82ffe2062cf12552 (patch)
treeb46efc63a181aab5e1d552aecb2b9f4a5089a1e7 /c/src/lib/libbsp/powerpc/shared/residual/Makefile.am
parent2003-12-02 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-a77cd06666febd2e8f34cd7d82ffe2062cf12552.tar.bz2
2003-12-02 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* bootloader/Makefile.am: Put all files into EXTRA_DIST. * vme/Makefile.am: Ditto. * console/Makefile.am: Move H_FILES to include_bsp_HEADERS. Add preinstallation dirstamp support. * irq/Makefile.am: Ditto. * motorola/Makefile.am: Ditto. * openpic/Makefile.am: Ditto. * pci/Makefile.am: Ditto. * residual/Makefile.am: Ditto. * vectors/Makefile.am: Ditto. * Makefile.am: Remove empty lines. * clock/Makefile.am: Ditto. * include/Makefile.am: Ditto. * startup/Makefile.am: Ditto.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/shared/residual/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/shared/residual/Makefile.am26
1 files changed, 16 insertions, 10 deletions
diff --git a/c/src/lib/libbsp/powerpc/shared/residual/Makefile.am b/c/src/lib/libbsp/powerpc/shared/residual/Makefile.am
index 53c396dd5f..0d457526b0 100644
--- a/c/src/lib/libbsp/powerpc/shared/residual/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/shared/residual/Makefile.am
@@ -2,22 +2,28 @@
## $Id$
##
-
C_FILES = residual.c
-H_FILES = pnp.h residual.h
+include_bspdir = $(includedir)/bsp
+include_bsp_HEADERS = pnp.h residual.h
+
+all-local: $(PREINSTALL_FILES)
-$(PROJECT_INCLUDE)/bsp:
- $(mkinstalldirs) $@
+EXTRA_DIST = residual.c
-$(PROJECT_INCLUDE)/bsp/%.h: %.h
- $(INSTALL_DATA) $< $@
+PREINSTALL_FILES =
-PREINSTALL_FILES = $(PROJECT_INCLUDE)/bsp \
- $(H_FILES:%.h=$(PROJECT_INCLUDE)/bsp/%.h)
+$(PROJECT_INCLUDE)/bsp/$(dirstamp):
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/bsp
+ @: > $(PROJECT_INCLUDE)/bsp/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/$(dirstamp)
-all-local: $(PREINSTALL_FILES)
+$(PROJECT_INCLUDE)/bsp/pnp.h: pnp.h $(PROJECT_INCLUDE)/bsp/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/bsp/pnp.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/pnp.h
-EXTRA_DIST = residual.c
+$(PROJECT_INCLUDE)/bsp/residual.h: residual.h $(PROJECT_INCLUDE)/bsp/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/bsp/residual.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/residual.h
include $(top_srcdir)/../../../automake/local.am