summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/shared/console/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 15:09:55 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 15:09:55 +0000
commite83c53545153e509482ef119070dcb6cd2582339 (patch)
tree61b723a4ee1d69e6e93960deecc68ce30d9d9bb5 /c/src/lib/libbsp/powerpc/shared/console/Makefile.am
parent2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e83c53545153e509482ef119070dcb6cd2582339.tar.bz2
2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* console/Makefile.am: Add PREINSTALL_DIRS. * irq/Makefile.am: Add PREINSTALL_DIRS. * motorola/Makefile.am: Add PREINSTALL_DIRS. * openpic/Makefile.am: Add PREINSTALL_DIRS. * pci/Makefile.am: Add PREINSTALL_DIRS. * residual/Makefile.am: Add PREINSTALL_DIRS. * vectors/Makefile.am: Add PREINSTALL_DIRS.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/shared/console/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/shared/console/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/powerpc/shared/console/Makefile.am b/c/src/lib/libbsp/powerpc/shared/console/Makefile.am
index 2291e5aa7c..7bbb0098f7 100644
--- a/c/src/lib/libbsp/powerpc/shared/console/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/shared/console/Makefile.am
@@ -11,12 +11,13 @@ all-local: $(PREINSTALL_FILES)
EXTRA_DIST = console.c inch.c polled_io.c uart.c reboot.c console.inl
+PREINSTALL_DIRS =
PREINSTALL_FILES =
$(PROJECT_INCLUDE)/bsp/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/bsp
@: > $(PROJECT_INCLUDE)/bsp/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/bsp/$(dirstamp)
$(PROJECT_INCLUDE)/bsp/consoleIo.h: consoleIo.h $(PROJECT_INCLUDE)/bsp/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/bsp/consoleIo.h
@@ -31,5 +32,6 @@ $(PROJECT_INCLUDE)/bsp/uart.h: uart.h $(PROJECT_INCLUDE)/bsp/$(dirstamp)
PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/uart.h
CLEANFILES = $(PREINSTALL_FILES)
+DISTCLEANFILES = $(PREINSTALL_DIRS)
include $(top_srcdir)/../../../automake/local.am