summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/score603e/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-31 00:37:44 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-31 00:37:44 +0000
commit66ae7d0b9fd9cce1b7121d84f677c1ef23fc0e6f (patch)
tree2777029b9878ae5869c4215740c1054bc78a1bca /c/src/lib/libbsp/powerpc/score603e/startup/Makefile.am
parent2004-01-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-66ae7d0b9fd9cce1b7121d84f677c1ef23fc0e6f.tar.bz2
2004-01-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in clock/Makefile.am, console/Makefile.am, PCI_bus/Makefile.am, startup/Makefile.am, timer/Makefile.am, tod/Makefile.am, vectors/Makefile.am. Use automake compilation rules. * clock/Makefile.am, console/Makefile.am, PCI_bus/Makefile.am, startup/Makefile.am, timer/Makefile.am, tod/Makefile.am, vectors/Makefile.am: Remove. * configure.ac: Reflect changes above. * wrapup/Makefile.am: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/score603e/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/score603e/startup/Makefile.am54
1 files changed, 0 insertions, 54 deletions
diff --git a/c/src/lib/libbsp/powerpc/score603e/startup/Makefile.am b/c/src/lib/libbsp/powerpc/score603e/startup/Makefile.am
deleted file mode 100644
index 71e6d857f2..0000000000
--- a/c/src/lib/libbsp/powerpc/score603e/startup/Makefile.am
+++ /dev/null
@@ -1,54 +0,0 @@
-##
-## $Id$
-##
-
-PGM = $(ARCH)/startup.rel
-
-#
-# First and second generation used different Bridge chips :(
-# Generation 1 --> 82378zb (now in the CVS Attic)
-# Generation 2 --> FPGA
-STARTUP_C_FILES = FPGA.c
-
-C_FILES = bspclean.c bspstart.c setvec.c Hwr_init.c spurious.c genpvec.c \
- $(STARTUP_C_FILES)
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-shared_C_FILES = $(top_srcdir)/../../shared/bootcard.c
-shared_C_FILES += $(top_srcdir)/../../shared/bsplibc.c
-shared_C_FILES += $(top_srcdir)/../../shared/bsppost.c
-shared_C_FILES += $(top_srcdir)/../../shared/main.c
-shared_C_FILES += $(top_srcdir)/../../shared/sbrk.c
-shared_C_FILES += $(top_srcdir)/../../shared/gnatinstallhandler.c
-OBJS += \
- $(shared_C_FILES:$(top_srcdir)/../../shared/%.c=$(ARCH)/%.$(OBJEXT))
-
-$(ARCH)/%.$(OBJEXT): $(top_srcdir)/../../shared/%.c $(ARCH)/$(dirstamp)
- ${COMPILE} -o $@ -c $<
-
-$(PGM): $(OBJS)
- $(make-rel)
-
-project_lib_DATA = linkcmds
-
-all-local: $(PGM) $(TMPINSTALL_FILES)
-
-EXTRA_DIST = $(C_FILES) linkcmds
-
-TMPINSTALL_FILES =
-
-$(PROJECT_LIB)/$(dirstamp):
- @$(mkdir_p) $(PROJECT_LIB)
- @: > $(PROJECT_LIB)/$(dirstamp)
-TMPINSTALL_FILES += $(PROJECT_LIB)/$(dirstamp)
-
-$(PROJECT_LIB)/linkcmds: linkcmds $(PROJECT_LIB)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds
-TMPINSTALL_FILES += $(PROJECT_LIB)/linkcmds
-
-CLEANFILES = $(TMPINSTALL_FILES)
-
-include $(top_srcdir)/../../../../automake/local.am