summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/score603e/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-31 00:37:44 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-31 00:37:44 +0000
commit66ae7d0b9fd9cce1b7121d84f677c1ef23fc0e6f (patch)
tree2777029b9878ae5869c4215740c1054bc78a1bca /c/src/lib/libbsp/powerpc/score603e/Makefile.am
parent2004-01-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-66ae7d0b9fd9cce1b7121d84f677c1ef23fc0e6f.tar.bz2
2004-01-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in clock/Makefile.am, console/Makefile.am, PCI_bus/Makefile.am, startup/Makefile.am, timer/Makefile.am, tod/Makefile.am, vectors/Makefile.am. Use automake compilation rules. * clock/Makefile.am, console/Makefile.am, PCI_bus/Makefile.am, startup/Makefile.am, timer/Makefile.am, tod/Makefile.am, vectors/Makefile.am: Remove. * configure.ac: Reflect changes above. * wrapup/Makefile.am: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/score603e/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/score603e/Makefile.am126
1 files changed, 122 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/powerpc/score603e/Makefile.am b/c/src/lib/libbsp/powerpc/score603e/Makefile.am
index 0fe9b21907..5c330f231a 100644
--- a/c/src/lib/libbsp/powerpc/score603e/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/score603e/Makefile.am
@@ -6,11 +6,15 @@ ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
# from the individual .rel files built in other directories
-SUBDIRS = . clock console startup timer tod PCI_bus vectors @exceptions@ \
- wrapup
+SUBDIRS = . @exceptions@ wrapup
+include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../bsp.am
+EXTRA_PROGRAMS =
+CLEANFILES =
+noinst_DATA =
+
include_HEADERS += include/coverhd.h include/gen2.h
include_HEADERS += include/tod.h
@@ -19,7 +23,117 @@ start$(LIB_VARIANT).$(OBJEXT): start/start.S
${CCASCOMPILE} -DASM -o $@ -c $<
project_lib_DATA = start$(LIB_VARIANT).$(OBJEXT)
-all-local: $(PREINSTALL_FILES)
+dist_project_lib_DATA += startup/linkcmds
+
+EXTRA_PROGRAMS += clock.rel
+CLEANFILES += clock.rel
+clock_rel_SOURCES = clock/clock.c
+clock_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+EXTRA_PROGRAMS += clock_g.rel
+CLEANFILES += clock_g.rel
+clock_g_rel_SOURCES = $(clock_rel_SOURCES)
+clock_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+clock_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += clock$(LIB_VARIANT).rel
+
+EXTRA_PROGRAMS += console.rel
+CLEANFILES += console.rel
+console_rel_SOURCES = console/85c30.c console/85c30.h console/console.c \
+ console/consolereserveresources.c console/tbl85c30.c \
+ console/consolebsp.h
+console_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+console_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+EXTRA_PROGRAMS += console_g.rel
+CLEANFILES += console_g.rel
+console_g_rel_SOURCES = $(console_rel_SOURCES)
+console_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+console_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += console$(LIB_VARIANT).rel
+
+# First and second generation used different Bridge chips :(
+# Generation 1 --> 82378zb (now in the CVS Attic)
+# Generation 2 --> FPGA
+EXTRA_PROGRAMS += startup.rel
+CLEANFILES += startup.rel
+startup_rel_SOURCES = startup/bspclean.c ../../shared/bsplibc.c \
+ ../../shared/bsppost.c startup/bspstart.c ../../shared/bootcard.c \
+ ../../shared/main.c ../../shared/sbrk.c startup/setvec.c \
+ startup/Hwr_init.c startup/spurious.c startup/genpvec.c \
+ ../../shared/gnatinstallhandler.c startup/FPGA.c
+startup_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+startup_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+EXTRA_PROGRAMS += startup_g.rel
+CLEANFILES += startup_g.rel
+startup_g_rel_SOURCES = $(startup_rel_SOURCES)
+startup_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+startup_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += startup$(LIB_VARIANT).rel
+
+EXTRA_PROGRAMS += timer.rel
+CLEANFILES += timer.rel
+timer_rel_SOURCES = timer/timer.c
+timer_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+EXTRA_PROGRAMS += timer_g.rel
+CLEANFILES += timer_g.rel
+timer_g_rel_SOURCES = $(timer_rel_SOURCES)
+timer_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+timer_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += timer$(LIB_VARIANT).rel
+
+EXTRA_PROGRAMS += tod.rel
+CLEANFILES += tod.rel
+tod_rel_SOURCES = tod/tod.c
+tod_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+tod_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+EXTRA_PROGRAMS += tod_g.rel
+CLEANFILES += tod_g.rel
+tod_g_rel_SOURCES = $(tod_rel_SOURCES)
+tod_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+tod_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += tod$(LIB_VARIANT).rel
+
+EXTRA_PROGRAMS += PCI_bus.rel
+CLEANFILES += PCI_bus.rel
+PCI_bus_rel_SOURCES = PCI_bus/PCI.c PCI_bus/PCI.h PCI_bus/flash.c \
+ PCI_bus/universe.c
+PCI_bus_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+PCI_bus_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+EXTRA_PROGRAMS += PCI_bus_g.rel
+CLEANFILES += PCI_bus_g.rel
+PCI_bus_g_rel_SOURCES = $(PCI_bus_rel_SOURCES)
+PCI_bus_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+PCI_bus_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += PCI_bus$(LIB_VARIANT).rel
+
+EXTRA_PROGRAMS += vectors.rel
+CLEANFILES += vectors.rel
+vectors_rel_SOURCES = vectors/vectors.S
+vectors_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+vectors_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+EXTRA_PROGRAMS += vectors_g.rel
+CLEANFILES += vectors_g.rel
+vectors_g_rel_SOURCES = $(vectors_rel_SOURCES)
+vectors_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+vectors_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += vectors$(LIB_VARIANT).rel
+
+all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
PREINSTALL_DIRS =
TMPINSTALL_FILES =
@@ -40,7 +154,11 @@ $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT): start$(LIB_VARIANT).$(OBJEXT) $(PR
$(INSTALL_DATA) $< $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
TMPINSTALL_FILES += $(PROJECT_LIB)/start$(LIB_VARIANT).$(OBJEXT)
-CLEANFILES = $(PREINSTALL_FILES)
+$(PROJECT_LIB)/linkcmds: startup/linkcmds $(PROJECT_LIB)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds
+TMPINSTALL_FILES += $(PROJECT_LIB)/linkcmds
+
+CLEANFILES += $(PREINSTALL_FILES)
DISTCLEANFILES = $(PREINSTALL_DIRS)
CLEANFILES += $(TMPINSTALL_FILES)