summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/score603e/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-02-12 03:31:07 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-02-12 03:31:07 +0000
commit5133bd66b7719450ad360d0e2a55a6d863a51818 (patch)
tree8991da9ed8b6a8880f2e0d5311f30b0107222ae0 /c/src/lib/libbsp/powerpc/score603e/Makefile.am
parent2005-02-11 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-5133bd66b7719450ad360d0e2a55a6d863a51818.tar.bz2
2005-02-11 Ralf Corsepius <ralf.corsepius@rtems.org>
* Makefile.am: Merge-in wrapup/Makefile.am. * wrapup/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/score603e/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/score603e/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/powerpc/score603e/Makefile.am b/c/src/lib/libbsp/powerpc/score603e/Makefile.am
index 9a53dcd99c..278727c063 100644
--- a/c/src/lib/libbsp/powerpc/score603e/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/score603e/Makefile.am
@@ -4,10 +4,6 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
-# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = . @exceptions@ wrapup
-
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../bsp.am
@@ -76,6 +72,12 @@ vectors_rel_SOURCES = vectors/vectors.S
vectors_rel_CPPFLAGS = $(AM_CPPFLAGS)
vectors_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+noinst_LIBRARIES = libbsp.a
+libbsp_a_SOURCES =
+libbsp_a_LIBADD = startup.rel clock.rel console.rel timer.rel tod.rel \
+ vectors.rel PCI_bus.rel
+libbsp_a_LIBADD += ../../../@RTEMS_CPU@/@exceptions@/rtems-cpu.rel
+
all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
PREINSTALL_DIRS =