summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/qoriq/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-09-08 08:10:26 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-09-12 10:00:32 +0200
commit356b1b8516bc16467feacf54ad0b602bee8261d1 (patch)
treec64d1322767f58712ad777e5a966e1db0b72b2a7 /c/src/lib/libbsp/powerpc/qoriq/Makefile.am
parentbsp/qoriq: Import ePAPR hcalls from Linux 4.12 (diff)
downloadrtems-356b1b8516bc16467feacf54ad0b602bee8261d1.tar.bz2
bsp/qoriq: Port ePAPR hcall interface to RTEMS
Update #3085.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/qoriq/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/qoriq/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/qoriq/Makefile.am b/c/src/lib/libbsp/powerpc/qoriq/Makefile.am
index 4bb0453ad8..b2c778bb07 100644
--- a/c/src/lib/libbsp/powerpc/qoriq/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/qoriq/Makefile.am
@@ -3,6 +3,8 @@ ACLOCAL_AMFLAGS = -I ../../../../aclocal
include $(top_srcdir)/../../../../automake/compile.am
include_bspdir = $(includedir)/bsp
+include_asmdir = $(includedir)/asm
+include_uapi_asmdir = $(includedir)/uapi/asm
dist_project_lib_DATA = bsp_specs
@@ -32,6 +34,13 @@ include_bsp_HEADERS = include/irq.h \
include/uart-bridge.h \
include/qoriq.h
+include_asm_HEADERS =
+include_asm_HEADERS += include/asm/epapr_hcalls.h
+include_asm_HEADERS += include/asm/fsl_hcalls.h
+
+include_uapi_asm_HEADERS =
+include_uapi_asm_HEADERS += include/uapi/asm/epapr_hcalls.h
+
noinst_LIBRARIES = libbspstart.a
libbspstart_a_SOURCES = start/start.S
project_lib_DATA = start.$(OBJEXT)
@@ -64,6 +73,7 @@ libbsp_a_SOURCES += \
../shared/src/tictac.c \
../shared/src/bsp-start-zero.S \
../shared/startup/bspidle.c \
+ startup/epapr_hcalls.S \
startup/l1cache.S \
startup/l2cache.S \
startup/mmu.c \