summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/psim/tools/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-03 18:37:51 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-03 18:37:51 +0000
commit001b41625e461404288c2e3ec7821992c06233ef (patch)
tree80052d3b071688cb86ce016a217241fea6e5254f /c/src/lib/libbsp/powerpc/psim/tools/configure.ac
parent2008-09-03 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-001b41625e461404288c2e3ec7821992c06233ef.tar.bz2
2008-09-03 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: Rework psim scripts to share code for creating device trees and actually running the tests. Overhaul the device tree generated to always include a block of Flash and a Real-Time Clock. When running MP tests enable the shared memory and semaphore devices. * psim-bottom, psim-gdb-bottom, psim-gdb-top.in, psim-shared, psim-top.in, runtest-bottom, runtest-top.in: New files. * psim, psim-gdb, runtest: Removed.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/psim/tools/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/psim/tools/configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/powerpc/psim/tools/configure.ac b/c/src/lib/libbsp/powerpc/psim/tools/configure.ac
index bb8f84aef4..98827f85dd 100644
--- a/c/src/lib/libbsp/powerpc/psim/tools/configure.ac
+++ b/c/src/lib/libbsp/powerpc/psim/tools/configure.ac
@@ -4,7 +4,7 @@
AC_PREREQ(2.60)
AC_INIT([rtems-c-src-lib-libbsp-powerpc-psim-tools],[_RTEMS_VERSION],[http://www.rtems.org/bugzilla])
-AC_CONFIG_SRCDIR([psim])
+AC_CONFIG_SRCDIR([psim-top.in])
RTEMS_TOP(../../../../../../..)
RTEMS_CANONICAL_TARGET_CPU
@@ -13,9 +13,15 @@ AM_INIT_AUTOMAKE([no-define foreign 1.10])
AM_MAINTAINER_MODE
RTEMS_ENV_RTEMSBSP
+RTEMS_PATH_KSH
+
RTEMS_PROJECT_ROOT
RTEMS_TOOLPATHS
# Explicitly list all Makefiles here
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile
+psim-top
+psim-gdb-top
+runtest-top
+])
AC_OUTPUT