summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/psim/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-11-21 18:34:28 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-11-21 18:34:28 +0000
commit6af8512c64724e43b66b76b7c787eb28dc0b7055 (patch)
tree4dcd7d3b755a36e2911f35fcacecfda786552fe1 /c/src/lib/libbsp/powerpc/psim/configure.ac
parent2001-11-20 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-6af8512c64724e43b66b76b7c787eb28dc0b7055.tar.bz2
2001-11-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add @exceptions@ to SUBDIRS. * configure.ac: Apply RTEMS_BSPOPTS_*(*) to merge-in settings from make/custom/psim.cfg; Remove RTEMS_OUTPUT_BUILD_SUBDIRS; Add RTEMS_PPC_EXCEPTIONS([old]). * include/Makefile.am: include force-preinstall.am. * wrapup/Makefile.am: Apply @exceptions@.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/psim/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/psim/configure.ac17
1 files changed, 15 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/powerpc/psim/configure.ac b/c/src/lib/libbsp/powerpc/psim/configure.ac
index 96db37f4d5..71228b97d6 100644
--- a/c/src/lib/libbsp/powerpc/psim/configure.ac
+++ b/c/src/lib/libbsp/powerpc/psim/configure.ac
@@ -25,6 +25,18 @@ AM_CONDITIONAL(HAS_MP,test "$HAS_MP" = "yes")
RTEMS_CONFIG_BUILD_SUBDIRS(tools)
+RTEMS_BSPOPTS_SET([PPC_USE_SPRG],[*],[0])
+RTEMS_BSPOPTS_HELP([PPC_USE_SPRG],
+[If defined, then the PowerPC specific code in RTEMS will use some
+of the special purpose registers to slightly optimize interrupt
+response time. The use of these registers can conflict with
+other tools like debuggers.])
+
+RTEMS_BSPOPTS_SET([PPC_VECTOR_FILE_BASE],[*],[0xFFF00100])
+RTEMS_BSPOPTS_HELP([PPC_VECTOR_FILE_BASE],
+[This defines the base address of the exception table.
+ NOTE: Vectors are actually at 0xFFF00000 but file starts at offset.])
+
AM_CONFIG_HEADER(include/bspopts.h)
RTEMS_PROJECT_ROOT
@@ -39,6 +51,7 @@ startup/Makefile
timer/Makefile
vectors/Makefile
wrapup/Makefile])
-AC_OUTPUT
-RTEMS_OUTPUT_BUILD_SUBDIRS(RTEMS_BUILD_SUBDIRS)
+RTEMS_PPC_EXCEPTIONS([old])
+
+AC_OUTPUT