summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/psim/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-05-15 15:54:15 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-05-15 15:54:15 +0000
commit4c94ffff2c016186c24911def5951445c9273c59 (patch)
treec6ffa6f7bf79fd35acd6d26286a6bde9fa6154cc /c/src/lib/libbsp/powerpc/psim/configure.ac
parent2008-05-15 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-4c94ffff2c016186c24911def5951445c9273c59.tar.bz2
2008-05-15 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac, startup/bspstart.c: Add capability for bootcard.c BSP Initialization Framework to ask the BSP where it has memory for the RTEMS Workspace and C Program Heap. These collectively are referred to as work area. If the BSP supports this, then it does not have to include code to split the available memory between the two areas. This reduces the amount of code in the BSP specific bspstart.c file. Additionally, the shared framework can initialize the C Library, call rtems_debug_enable(), and dirty the work area memory. Until most/all BSPs support this new capability, if the BSP supports this, it should call RTEMS_BSP_BOOTCARD_HANDLES_RAM_ALLOCATION from its configure.ac. When the transition is complete, this autoconf macro can be removed.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/psim/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/psim/configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/c/src/lib/libbsp/powerpc/psim/configure.ac b/c/src/lib/libbsp/powerpc/psim/configure.ac
index 79c1c5a5df..2398aeb12e 100644
--- a/c/src/lib/libbsp/powerpc/psim/configure.ac
+++ b/c/src/lib/libbsp/powerpc/psim/configure.ac
@@ -29,11 +29,7 @@ RTEMS_BSPOPTS_HELP([PPC_VECTOR_FILE_BASE],
[This defines the base address of the exception table.
NOTE: Vectors are actually at 0xFFF00000 but file starts at offset.])
-RTEMS_BSPOPTS_SET([BSP_DIRTY_MEMORY],[*],[0])
-RTEMS_BSPOPTS_HELP([BSP_DIRTY_MEMORY],
-[If defined, then PSIM will put a non-zero pattern into the RTEMS
- Workspace and C program heap. This should assist in finding
- code that assumes memory starts set to zero.])
+RTEMS_BSP_BOOTCARD_HANDLES_RAM_ALLOCATION
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile])