summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/psim/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-07-16 20:22:00 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-07-16 20:22:00 +0000
commit10f095c83f14452748b676c5d4fa5c803fed411a (patch)
tree9e1d21ab5aa826bf50991a6da088f7dbf0242289 /c/src/lib/libbsp/powerpc/psim/configure.ac
parent2008-07-16 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-10f095c83f14452748b676c5d4fa5c803fed411a.tar.bz2
2008-07-16 Joel Sherrill <joel.sherrill@oarcorp.com>
* configure.ac: Add fast idle.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/psim/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/psim/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/psim/configure.ac b/c/src/lib/libbsp/powerpc/psim/configure.ac
index 2398aeb12e..a0f26228ef 100644
--- a/c/src/lib/libbsp/powerpc/psim/configure.ac
+++ b/c/src/lib/libbsp/powerpc/psim/configure.ac
@@ -29,6 +29,12 @@ RTEMS_BSPOPTS_HELP([PPC_VECTOR_FILE_BASE],
[This defines the base address of the exception table.
NOTE: Vectors are actually at 0xFFF00000 but file starts at offset.])
+RTEMS_BSPOPTS_SET([CLOCK_DRIVER_USE_FAST_IDLE],[psim],[1])
+RTEMS_BSPOPTS_HELP([CLOCK_DRIVER_USE_FAST_IDLE],
+[This sets a mode where the time runs as fast as possible when
+ a clock ISR occurs while the IDLE thread is executing. This can
+ significantly reduce simulation times.])
+
RTEMS_BSP_BOOTCARD_HANDLES_RAM_ALLOCATION
# Explicitly list all Makefiles here