summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/ppcn_60x/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 13:11:22 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 13:11:22 +0000
commitdb0b36999d611a0e4b555cde9dc3210e41d5e1bc (patch)
tree39d6ec4337bfe101d0af32632b11ea92993556ef /c/src/lib/libbsp/powerpc/ppcn_60x/Makefile.am
parent2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-db0b36999d611a0e4b555cde9dc3210e41d5e1bc.tar.bz2
2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. Reflect changes to bsp.am. * include/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/ppcn_60x/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/ppcn_60x/Makefile.am30
1 files changed, 26 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/powerpc/ppcn_60x/Makefile.am b/c/src/lib/libbsp/powerpc/ppcn_60x/Makefile.am
index f088c59c23..88a61e884a 100644
--- a/c/src/lib/libbsp/powerpc/ppcn_60x/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/ppcn_60x/Makefile.am
@@ -5,13 +5,35 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = include clock console startup start timer tod network universe pci \
- nvram vectors @exceptions@ wrapup
+# from the individual .rel files built in other directories
+SUBDIRS = . clock console startup start timer tod network universe pci nvram \
+ vectors @exceptions@ wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = STATUS bsp_specs
+nodist_include_HEADERS += $(top_srcdir)/../../shared/include/coverhd.h
+include_HEADERS += include/tod.h
+include_HEADERS += include/nvram.h include/pci.h
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = STATUS
+
+$(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
+
+$(PROJECT_INCLUDE)/tod.h: include/tod.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/tod.h
+
+$(PROJECT_INCLUDE)/nvram.h: include/nvram.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/nvram.h
+
+$(PROJECT_INCLUDE)/pci.h: include/pci.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/pci.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am