summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mvme5500/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-22 21:50:25 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-22 21:50:25 +0000
commit5734337319c6089887f4f025d87687a5fdbd741b (patch)
tree22eb5722897ed985926b5f0a59624199d1d7d264 /c/src/lib/libbsp/powerpc/mvme5500/Makefile.am
parent2008-09-22 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-5734337319c6089887f4f025d87687a5fdbd741b.tar.bz2
2008-09-22 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, README.booting, include/bsp.h, startup/bspclean.c, vectors/exceptionhandler.c: Use standardized bsp_cleanup() which can optionally print a message, poll for user to press key, and call bsp_reset(). Using this eliminates the various bsp_cleanup() implementations which had their own implementation and variety of string constants. * startup/bspreset.c: New file. * startup/reboot.c: Removed.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/mvme5500/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/mvme5500/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/powerpc/mvme5500/Makefile.am b/c/src/lib/libbsp/powerpc/mvme5500/Makefile.am
index 0af857d947..0e88320307 100644
--- a/c/src/lib/libbsp/powerpc/mvme5500/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/mvme5500/Makefile.am
@@ -36,7 +36,7 @@ startup_SOURCES = startup/bspstart.c \
../../powerpc/shared/startup/sbrk.c ../../shared/bootcard.c \
../../shared/bsppredriverhook.c startup/bspclean.c \
../../shared/bsplibc.c ../../shared/bsppost.c \
- ../../shared/gnatinstallhandler.c startup/reboot.c
+ ../../shared/gnatinstallhandler.c startup/bspreset.c
pclock_SOURCES = ../../powerpc/shared/clock/p_clock.c
include_bsp_HEADERS = ../../powerpc/shared/console/uart.h