summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mpc55xxevb/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2013-01-11 14:41:53 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2013-01-28 16:45:42 +0100
commitc934a10dba246ef00390dbe64b75a966344dcf6b (patch)
treec25b0bab39f3baf16cc854b5b55a4bc32d24d1fb /c/src/lib/libbsp/powerpc/mpc55xxevb/configure.ac
parentbsps/powerpc: Add option for write-through cache (diff)
downloadrtems-c934a10dba246ef00390dbe64b75a966344dcf6b.tar.bz2
bsp/mpc55xx: Add BSP_DATA_CACHE_USE_WRITE_THROUGH
Diffstat (limited to 'c/src/lib/libbsp/powerpc/mpc55xxevb/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/mpc55xxevb/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/mpc55xxevb/configure.ac b/c/src/lib/libbsp/powerpc/mpc55xxevb/configure.ac
index e691b364d8..63f6a9187d 100644
--- a/c/src/lib/libbsp/powerpc/mpc55xxevb/configure.ac
+++ b/c/src/lib/libbsp/powerpc/mpc55xxevb/configure.ac
@@ -32,6 +32,11 @@ RTEMS_BSPOPTS_SET_INSTRUCTION_CACHE_ENABLED([gwlcfm],[])
RTEMS_BSPOPTS_SET_INSTRUCTION_CACHE_ENABLED([*],[1])
RTEMS_BSPOPTS_HELP_INSTRUCTION_CACHE_ENABLED
+RTEMS_BSPOPTS_SET([BSP_DATA_CACHE_USE_WRITE_THROUGH],[mpc5674f_ecu508*],[1])
+RTEMS_BSPOPTS_SET([BSP_DATA_CACHE_USE_WRITE_THROUGH],[*],[])
+RTEMS_BSPOPTS_HELP([BSP_DATA_CACHE_USE_WRITE_THROUGH],
+[use write-through for data cache])
+
RTEMS_BSPOPTS_SET([PPC_EXC_CONFIG_USE_FIXED_HANDLER],[*],[1])
RTEMS_BSPOPTS_HELP([PPC_EXC_CONFIG_USE_FIXED_HANDLER],
[use fixed high-level exception handler])