summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/motorola_powerpc/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-09 14:52:20 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-09 14:52:20 +0000
commit84f0cfb5f1a679b25d60235eb713cb567ebc1d2e (patch)
tree453ca71ebb4a7f3c39d216edb09a22f579307d1c /c/src/lib/libbsp/powerpc/motorola_powerpc/startup/Makefile.am
parent2003-12-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-84f0cfb5f1a679b25d60235eb713cb567ebc1d2e.tar.bz2
2003-12-09 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* bootloader/Makefile.am: Misc cleanups and fixes. * motorola/Makefile.am: Misc cleanups and fixes. * start/Makefile.am: Misc cleanups and fixes. * startup/Makefile.am: Misc cleanups and fixes. * startup/linkcmds: Preparations for gcc-3.3.x.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/motorola_powerpc/startup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/motorola_powerpc/startup/Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/c/src/lib/libbsp/powerpc/motorola_powerpc/startup/Makefile.am b/c/src/lib/libbsp/powerpc/motorola_powerpc/startup/Makefile.am
index c544fe8b6f..742c62fe8a 100644
--- a/c/src/lib/libbsp/powerpc/motorola_powerpc/startup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/motorola_powerpc/startup/Makefile.am
@@ -4,6 +4,8 @@
VPATH = @srcdir@:@srcdir@/../console:@srcdir@/../../shared/startup:@srcdir@/../../../shared
+PGM = $(ARCH)/startup.rel
+
C_FILES = bootcard.c main.c bspstart.c bsppost.c bsplibc.c sbrk.c bspclean.c \
gnatinstallhandler.c pgtbl_setup.c pgtbl_activate.c
C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
@@ -17,19 +19,17 @@ include $(top_srcdir)/../../../../automake/lib.am
# (OPTIONAL) Add local stuff here using +=
#
-bsplib_DATA = linkcmds
-
-$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
- $(INSTALL_DATA) $< $@
+$(PGM): $(OBJS)
+ $(make-rel)
-# FIXME: This should not be here
-# $(PROJECT_RELEASE)/lib/libbsp.a:
-# cd ../wrapup; $(MAKE) $(AM_MAKEFLAGS)
+project_lib_DATA = linkcmds
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds
-
-all-local: $(OBJS) $(TMPINSTALL_FILES)
+all-local: $(PGM) $(TMPINSTALL_FILES)
EXTRA_DIST = linkcmds
+${PROJECT_RELEASE}/lib/linkcmds: linkcmds ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds
+
include $(top_srcdir)/../../../../automake/local.am