summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-11-21 18:38:48 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-11-21 18:38:48 +0000
commit4fe0abdcd129d27ce1e0b63ed9f8085c0e0bc766 (patch)
treedc872a32b975822c02a0227d050c1efef6a3ae53 /c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac
parent2001-11-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4fe0abdcd129d27ce1e0b63ed9f8085c0e0bc766.tar.bz2
2001-11-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add @exceptions@ to SUBDIRS; Remove need_motorola_powerpc. * configure.ac: Apply RTEMS_BSPOPTS_*(*) to merge-in settings from make/custom/mcp750.cfg, make/custom/mvme2307.cfg; Remove need_motorola_powerpc; Add RTEMS_PPC_EXCEPTIONS([new]). * include/Makefile.am: Replace PREINSTALL_FILES with TMPINSTALL_FILES, include force-preinstall.am. * wrapup/Makefile.am: Apply @exceptions@.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac')
-rw-r--r--c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac b/c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac
index 879374f718..919e072a03 100644
--- a/c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac
+++ b/c/src/lib/libbsp/powerpc/motorola_powerpc/configure.ac
@@ -23,11 +23,18 @@ RTEMS_CHECK_NETWORKING
RTEMS_CANONICAL_HOST
AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
-AM_CONDITIONAL(need_motorola_powerpc, test "$RTEMS_BSP_FAMILY" = "motorola_powerpc")
-
AS=$CC
AM_PROG_AS
+RTEMS_BSPOPTS_SET([PPC_USE_DATA_CACHE],[*],[1])
+RTEMS_BSPOPTS_HELP([PPC_USE_DATA_CACHE],
+[If defined, then the PowerPC specific code in RTEMS will use
+ data cache instructions to optimize the context switch code.
+ This code can conflict with debuggers or emulators. It is known
+ to break the Corelis PowerPC emulator with at least some combinations
+ of PowerPC 603e revisions and emulator versions.
+ The BSP actually contains the call that enables this.])
+
AM_CONFIG_HEADER(include/bspopts.h)
RTEMS_PROJECT_ROOT
@@ -46,4 +53,7 @@ start/Makefile
startup/Makefile
vectors/Makefile
wrapup/Makefile])
+
+RTEMS_PPC_EXCEPTIONS([new])
+
AC_OUTPUT