summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 13:22:48 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 13:22:48 +0000
commit23090f33860ae60badb5eb6e781e99a79801720a (patch)
tree1fbc8b5584aac3f3e51cf2861ad22d97bbc9aba2 /c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am
parent2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-23090f33860ae60badb5eb6e781e99a79801720a.tar.bz2
2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. Reflect changes to bsp.am. * include/Makefile.am: Remove. * include/bsp.h: Add copy of ../shared/include/bsp.h (Violates BSP coding standards). * configure.ac: Reflect changes above. * irq/Makefile.am: Fix header installation. * motorola/Makefile.am: Fix header installation. * openpic/Makefile.am: Fix header installation. * pci/Makefile.am: Fix header installation.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am49
1 files changed, 44 insertions, 5 deletions
diff --git a/c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am b/c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am
index 4804bba569..3764bc2e32 100644
--- a/c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/motorola_powerpc/Makefile.am
@@ -5,14 +5,53 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = include clock console pci residual openpic irq vectors start \
- startup bootloader motorola @exceptions@ vme wrapup
+# from the individual .rel files built in other directories
+SUBDIRS = . clock console pci residual openpic irq vectors start startup \
+ bootloader motorola @exceptions@ vme wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = BOOTING README.MVME2300 README.OTHERBOARDS README.dec21140 \
- bsp_specs times.mcp750 times.mvme2307
+include_bspdir = $(includedir)/bsp
+
+nodist_include_HEADERS += ../shared/include/nvram.h
+nodist_include_HEADERS += ../../shared/include/coverhd.h
+nodist_include_bsp_HEADERS = ../shared/console/consoleIo.h
+nodist_include_bsp_HEADERS += ../shared/console/uart.h
+nodist_include_bsp_HEADERS += ../shared/irq/irq.h
+nodist_include_bsp_HEADERS += ../shared/motorola/motorola.h
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = BOOTING README.MVME2300 README.OTHERBOARDS README.dec21140
+EXTRA_DIST += times.mcp750 times.mvme2307
+
+$(PROJECT_INCLUDE)/bsp:
+ @$(mkinstalldirs) $(PROJECT_INCLUDE)/bsp
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp
+
+$(PROJECT_INCLUDE)/bsp/consoleIo.h: ../shared/console/consoleIo.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/consoleIo.h
+
+$(PROJECT_INCLUDE)/bsp/uart.h: ../shared/console/uart.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/uart.h
+
+$(PROJECT_INCLUDE)/bsp/irq.h: ../shared/irq/irq.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/irq.h
+
+$(PROJECT_INCLUDE)/bsp/motorola.h: ../shared/motorola/motorola.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/motorola.h
+
+$(PROJECT_INCLUDE)/nvram.h: ../shared/include/nvram.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/nvram.h
+
+$(PROJECT_INCLUDE)/coverhd.h: ../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am