summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/mbx8xx/ide/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2003-03-25 18:18:01 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2003-03-25 18:18:01 +0000
commitebe5abc87c2d56bfa8d3d6b671090c7edc062ebb (patch)
treeee15d40fad7c010ed7d54c8ecb163cc33eb2e06c /c/src/lib/libbsp/powerpc/mbx8xx/ide/Makefile.am
parent2003-03-25 Thomas Doerfler <Thomas.Doerfler@imd-systems.de> (diff)
downloadrtems-ebe5abc87c2d56bfa8d3d6b671090c7edc062ebb.tar.bz2
2003-03-25 Thomas Doerfler <Thomas.Doerfler@imd-systems.de>
PR 368/filesystem * ide/*: added BSP support for libchip standard ide driver
Diffstat (limited to 'c/src/lib/libbsp/powerpc/mbx8xx/ide/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/mbx8xx/ide/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/powerpc/mbx8xx/ide/Makefile.am b/c/src/lib/libbsp/powerpc/mbx8xx/ide/Makefile.am
new file mode 100644
index 0000000000..ef3157533e
--- /dev/null
+++ b/c/src/lib/libbsp/powerpc/mbx8xx/ide/Makefile.am
@@ -0,0 +1,32 @@
+##
+## Makefile.am,v 1.5 2002/08/11 06:59:03 ralf Exp
+##
+
+
+PGM = # $(ARCH)/console.rel
+
+C_FILES = idecfg.c pcmcia_ide.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): $(OBJS)
+ $(make-rel)
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+all-local: $(ARCH) $(OBJS) $(PGM)
+
+.PRECIOUS: $(PGM)
+
+EXTRA_DIST = idecfg.c
+
+include $(top_srcdir)/../../../../../../automake/local.am